app-leechcraft/lc-aggregator: fix qtsql flags dependencies
author0xd34df00d <0xd34df00d@gmail.com>
Sat, 4 Apr 2020 20:47:20 +0000 (16:47 -0400)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 9 Apr 2020 12:37:42 +0000 (15:37 +0300)
sqlite, postgres, etc flags are only relevant at runtime for QtSql.

Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Georg Rudoy <0xd34df00d@gmail.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-leechcraft/lc-aggregator/lc-aggregator-9999.ebuild

index 1b1effd49285043e2001b79de5251ece06fc3377..cb80b05f0ae256f2cd6d3cab7731a1ac136e2cce 100644 (file)
@@ -1,7 +1,7 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 inherit leechcraft
 
@@ -9,19 +9,21 @@ DESCRIPTION="Full-featured RSS/Atom feed reader for LeechCraft"
 
 SLOT="0"
 KEYWORDS=""
-IUSE="debug mysql +sqlite postgres"
+IUSE="debug mysql postgres +sqlite"
 
 DEPEND="
-       ~app-leechcraft/lc-core-${PV}[postgres?,sqlite?]
+       ~app-leechcraft/lc-core-${PV}[postgres?]
        dev-qt/qtcore:5
        dev-qt/qtnetwork:5
        dev-qt/qtprintsupport:5
-       dev-qt/qtsql:5[sqlite?,postgres?,mysql?]
+       dev-qt/qtsql:5
        dev-qt/qtwebkit:5
        dev-qt/qtwidgets:5
        dev-qt/qtxml:5"
 RDEPEND="${DEPEND}
-               virtual/leechcraft-downloader-http"
+       dev-qt/qtsql:5[mysql?,postgres?,sqlite?]
+       virtual/leechcraft-downloader-http
+"
 
 REQUIRED_USE="|| ( mysql sqlite postgres )"