app-misc/gtypist: fix crash and upgrade EAPI
authorArjan Adriaanse <arjan@adriaan.se>
Mon, 4 May 2020 02:38:13 +0000 (04:38 +0200)
committerMike Gilbert <floppym@gentoo.org>
Tue, 5 May 2020 03:06:09 +0000 (23:06 -0400)
Closes: https://bugs.gentoo.org/698764
Signed-off-by: Arjan Adriaanse <arjan@adriaan.se>
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Closes: https://github.com/gentoo/gentoo/pull/15639

app-misc/gtypist/files/gtypist-2.9.5-link-infow.patch [new file with mode: 0644]
app-misc/gtypist/gtypist-2.9.5-r1.ebuild [moved from app-misc/gtypist/gtypist-2.9.5.ebuild with 83% similarity]

diff --git a/app-misc/gtypist/files/gtypist-2.9.5-link-infow.patch b/app-misc/gtypist/files/gtypist-2.9.5-link-infow.patch
new file mode 100644 (file)
index 0000000..736a031
--- /dev/null
@@ -0,0 +1,15 @@
+diff --git a/configure.ac b/configure.ac
+index 8742d93..e350926 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -56,8 +56,8 @@ else
+        "further information. On Debian/Ubuntu you need to install libncursesw5-dev."
+    exit 1;
+ fi
+-AC_SEARCH_LIBS(cbreak, tinfo, [],
+-  [AC_MSG_ERROR([Can't find cbreak() in -lncursesw or -ltinfo])])
++AC_SEARCH_LIBS(cbreak, tinfow, [],
++  [AC_MSG_ERROR([Can't find cbreak() in -lncursesw or -ltinfow])])
+ # iconv
similarity index 83%
rename from app-misc/gtypist/gtypist-2.9.5.ebuild
rename to app-misc/gtypist/gtypist-2.9.5-r1.ebuild
index 0ecb2e7fd2255545bbe597730172bf2566c287d0..dc5ae156662e1e1401fa2bf86a290e3080cf3544 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
-inherit eutils elisp-common
+EAPI=7
+inherit elisp-common autotools
 
 DESCRIPTION="Universal typing tutor"
 HOMEPAGE="https://www.gnu.org/software/gtypist/"
@@ -27,8 +27,17 @@ src_unpack() {
        unpack ${P}.tar.xz
 }
 
+PATCHES=(
+       "${FILESDIR}"/${PN}-2.8.3-xemacs-compat.patch
+
+       # solution from https://bugs.gentoo.org/698764#c0
+       "${FILESDIR}"/${PN}-2.9.5-link-infow.patch
+)
+
 src_prepare() {
-       epatch "${FILESDIR}"/${PN}-2.8.3-xemacs-compat.patch
+       default
+
+       eaclocal && eautomake
 }
 
 src_configure() {