dev-python/oslo-service: adding for liberty
authorMatthew Thode <mthode@mthode.org>
Thu, 3 Sep 2015 21:55:42 +0000 (16:55 -0500)
committerMatthew Thode <mthode@mthode.org>
Thu, 3 Sep 2015 22:00:22 +0000 (17:00 -0500)
dev-python/oslo-service/Manifest [new file with mode: 0644]
dev-python/oslo-service/metadata.xml [new file with mode: 0644]
dev-python/oslo-service/oslo-service-0.9.0.ebuild [new file with mode: 0644]

diff --git a/dev-python/oslo-service/Manifest b/dev-python/oslo-service/Manifest
new file mode 100644 (file)
index 0000000..5889a76
--- /dev/null
@@ -0,0 +1 @@
+DIST oslo.service-0.9.0.tar.gz 57558 SHA256 f77753910391a1b2bd7fd9b5b863d7230b1ff727443dd2efcb725ce937ffb566 SHA512 6e17d1e28682732c8866e43f509a7fd7f69d2718493de3dab939600207e56fd0622036ff62928b9855b6219729e1173e62e1a1c949959a5d2d58eeeded97a1e2 WHIRLPOOL be645ac0d461056d5df4d17bbfe6f3819d6eba4fd2764459d287badf056d5c962e2c690b64fceba72160094ca1d29ff5f6c7708fef90bd192faa8ba532a4d4bb
diff --git a/dev-python/oslo-service/metadata.xml b/dev-python/oslo-service/metadata.xml
new file mode 100644 (file)
index 0000000..d5dfd32
--- /dev/null
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer>
+               <email>prometheanfire@gentoo.org</email>
+               <name>Matthew Thode</name>
+       </maintainer>
+       <longdescription lang="en">
+       </longdescription>
+</pkgmetadata>
diff --git a/dev-python/oslo-service/oslo-service-0.9.0.ebuild b/dev-python/oslo-service/oslo-service-0.9.0.ebuild
new file mode 100644 (file)
index 0000000..9b1f4f6
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for running OpenStack services"
+HOMEPAGE="https://pypi.python.org/pypi/oslo.service"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.service/oslo.service-${PV}.tar.gz"
+S="${WORKDIR}/oslo.service-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+CDEPEND="
+       >=dev-python/pbr-1.3[${PYTHON_USEDEP}]
+       <dev-python/pbr-2.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}
+       test? (
+               >=dev-python/mock-1.2[${PYTHON_USEDEP}]
+               >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+               >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+               >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+               !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+               <dev-python/sphinx-1.3.0[${PYTHON_USEDEP}]
+       )"
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+       >=dev-python/webob-1.2.3[${PYTHON_USEDEP}]
+       >=dev-python/eventlet-0.17.4[${PYTHON_USEDEP}]
+       >=dev-python/greenlet-0.3.2[${PYTHON_USEDEP}]
+       >=dev-python/monotonic-0.3[${PYTHON_USEDEP}]
+       >=dev-python/oslo-utils-2.0.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-concurrency-2.3.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-config-2.3.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-log-1.8.0[${PYTHON_USEDEP}]
+       >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-i18n-1.5.0[${PYTHON_USEDEP}]
+       >=dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}]
+       >=dev-python/routes-1.12.3[${PYTHON_USEDEP}]
+       dev-python/paste[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+       sed -i '/^hacking/d' test-requirements.txt || die
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       nosetests tests/ || die "test failed under ${EPYTHON}"
+}