Version bumped.
authorMatsuu Takuto <matsuu@gentoo.org>
Wed, 12 Oct 2011 17:00:42 +0000 (17:00 +0000)
committerMatsuu Takuto <matsuu@gentoo.org>
Wed, 12 Oct 2011 17:00:42 +0000 (17:00 +0000)
Package-Manager: portage-2.1.10.22/cvs/Linux x86_64

dev-ruby/facter/ChangeLog
dev-ruby/facter/facter-1.5.2-r1.ebuild [deleted file]
dev-ruby/facter/facter-1.5.7-r1.ebuild [deleted file]
dev-ruby/facter/facter-1.6.2.ebuild [new file with mode: 0644]

index e8f1ec278e80cc3bef2e2651897c0ca193359f0d..f36e61636c13d0a379b72ce7e2b37d90237bef68 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-ruby/facter
 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/facter/ChangeLog,v 1.42 2011/10/09 17:25:48 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/facter/ChangeLog,v 1.43 2011/10/12 17:00:42 matsuu Exp $
+
+*facter-1.6.2 (12 Oct 2011)
+
+  12 Oct 2011; MATSUU Takuto <matsuu@gentoo.org> -facter-1.5.2-r1.ebuild,
+  -facter-1.5.7-r1.ebuild, +facter-1.6.2.ebuild:
+  Version bumped. Removed old versions.
 
   09 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> facter-1.6.0.ebuild:
   ppc stable wrt #380525
diff --git a/dev-ruby/facter/facter-1.5.2-r1.ebuild b/dev-ruby/facter/facter-1.5.2-r1.ebuild
deleted file mode 100644 (file)
index d4cc61a..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/facter/facter-1.5.2-r1.ebuild,v 1.5 2009/08/09 12:20:53 nixnut Exp $
-
-inherit ruby
-
-DESCRIPTION="A cross-platform Ruby library for retrieving facts from operating systems"
-LICENSE="GPL-2"
-HOMEPAGE="http://reductivelabs.com/projects/facter/index.html"
-SRC_URI="http://reductivelabs.com/downloads/${PN}/${P}.tgz"
-
-SLOT="0"
-IUSE=""
-KEYWORDS="amd64 ppc ~ppc64 sparc x86"
-
-USE_RUBY="ruby18"
-
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-       epatch "${FILESDIR}"/${P}-virtual.patch
-}
-
-src_compile() {
-       :
-}
-
-src_install() {
-       DESTDIR="${D}" ruby_einstall || die
-       DESTDIR="${D}" erubydoc
-}
diff --git a/dev-ruby/facter/facter-1.5.7-r1.ebuild b/dev-ruby/facter/facter-1.5.7-r1.ebuild
deleted file mode 100644 (file)
index 5fb5113..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/facter/facter-1.5.7-r1.ebuild,v 1.6 2010/11/04 06:49:59 matsuu Exp $
-
-EAPI="2"
-
-inherit ruby
-
-DESCRIPTION="A cross-platform Ruby library for retrieving facts from operating systems"
-LICENSE="GPL-2"
-HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
-SRC_URI="http://reductivelabs.com/downloads/${PN}/${P}.tar.gz"
-
-SLOT="0"
-IUSE=""
-KEYWORDS="~amd64 hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-
-USE_RUBY="ruby18"
-
-src_prepare() {
-       epatch "${FILESDIR}"/${PN}-1.5.7-fqdn.patch
-       epatch "${FILESDIR}"/${PN}-1.5.7-virtual.patch
-}
-
-src_compile() {
-       :
-}
-
-src_install() {
-       DESTDIR="${D}" ruby_einstall || die
-       DESTDIR="${D}" erubydoc
-}
diff --git a/dev-ruby/facter/facter-1.6.2.ebuild b/dev-ruby/facter/facter-1.6.2.ebuild
new file mode 100644 (file)
index 0000000..b84a614
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/facter/facter-1.6.2.ebuild,v 1.1 2011/10/12 17:00:42 matsuu Exp $
+
+EAPI="4"
+
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+RUBY_FAKEGEM_BINWRAP="facter"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A cross-platform Ruby library for retrieving facts from operating systems"
+HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+
+ruby_add_bdepend "test? (
+               dev-ruby/mocha
+               dev-ruby/rspec:2
+       )"