dev-python/google-api-python-client: Version bump, add py38
authorPatrick McLean <patrick.mclean@sony.com>
Wed, 13 May 2020 04:11:52 +0000 (21:11 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Wed, 13 May 2020 06:41:34 +0000 (23:41 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/google-api-python-client/Manifest
dev-python/google-api-python-client/files/google-api-python-client-1.8.3-tests.patch [new file with mode: 0644]
dev-python/google-api-python-client/google-api-python-client-1.8.3.ebuild [new file with mode: 0644]

index 00febd194c2880f25f65747e035a4cfb8e323486..0342a200dc34b8a536c0479a9de30153e1715f2a 100644 (file)
@@ -1,2 +1,3 @@
 DIST google-api-python-client-1.6.5.tar.gz 4255929 BLAKE2B 4e2197fe56f25cd202f7a0b3f64b3796158d798bfedb9c0690a59c24bd5ce10fbe0300093ebb76cd343dae5eea2a0a360903cd0890834241926fd55a7dc07ea9 SHA512 b2f2be81e6f54ee3065e75ea064ea3ae49cb983d401ac46dca8459409dbd6df7c3ba07798285b5177bfa632a20d43aaaef3a7c73d5d565796567b8b305737565
 DIST google-api-python-client-1.7.9.tar.gz 4142239 BLAKE2B 1754162cd7ae5aa64e105e4842ac415473949064576241453ba5aefcc9c53e3a070167d4210f49509a5f63d4b9e79fa5377119ccd53acafe24eaad4a39e5f8c7 SHA512 1e4410c5e639a6bd3cf12b3e648a63e0098182bb52196085dc92597a38e98984fd349adc282d688aa58ec263502d984f54c7827b7ce53128811e7137234358b6
+DIST google-api-python-client-1.8.3.tar.gz 13537177 BLAKE2B 00b1d46f349a8ad66d08a01da31aed224260ad38f0ee2d7a5b68afe29264234475d28b33cd95addf9f7020fa052e9528b01a4c9cdb73e2ca5742134c4f8f86b5 SHA512 7b9138b27bf032cc1b8beb321459ba5935ed31e4965fa783e472b9483cfd0e97c1da6a34e84fb8c939c462fac462d3f0d853266586ab37be8f890a6b873cf4e6
diff --git a/dev-python/google-api-python-client/files/google-api-python-client-1.8.3-tests.patch b/dev-python/google-api-python-client/files/google-api-python-client-1.8.3-tests.patch
new file mode 100644 (file)
index 0000000..ad875e7
--- /dev/null
@@ -0,0 +1,28 @@
+diff --git a/tests/test_discovery.py b/tests/test_discovery.py
+index 6400f214..c999fd4f 100644
+--- a/tests/test_discovery.py
++++ b/tests/test_discovery.py
+@@ -40,6 +40,7 @@ import sys
+ import unittest2 as unittest
+ import mock
++import pytest
+ import google.auth.credentials
+ import google_auth_httplib2
+@@ -515,6 +516,7 @@ class DiscoveryFromDocument(unittest.TestCase):
+         # application default credentials were used.
+         self.assertNotIsInstance(plus._http, google_auth_httplib2.AuthorizedHttp)
++    @pytest.mark.skip("Needs network access and credentials")
+     def test_api_endpoint_override_from_client_options(self):
+         discovery = open(datafile("plus.json")).read()
+         api_endpoint = "https://foo.googleapis.com/"
+@@ -525,6 +527,7 @@ class DiscoveryFromDocument(unittest.TestCase):
+         self.assertEqual(plus._baseUrl, api_endpoint)
++    @pytest.mark.skip("Needs network access and credentials")
+     def test_api_endpoint_override_from_client_options_dict(self):
+         discovery = open(datafile("plus.json")).read()
+         api_endpoint = "https://foo.googleapis.com/"
diff --git a/dev-python/google-api-python-client/google-api-python-client-1.8.3.ebuild b/dev-python/google-api-python-client/google-api-python-client-1.8.3.ebuild
new file mode 100644 (file)
index 0000000..41edd77
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://github.com/google/google-api-python-client"
+SRC_URI="https://github.com/google/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       dev-python/chardet[${PYTHON_USEDEP}]
+       >=dev-python/httplib2-0.9.2[${PYTHON_USEDEP}]
+       <dev-python/httplib2-1[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       dev-python/google-api-core[${PYTHON_USEDEP}]
+       >=dev-python/google-auth-1.4.1[${PYTHON_USEDEP}]
+       >=dev-python/google-auth-httplib2-0.0.3[${PYTHON_USEDEP}]
+       >=dev-python/uritemplate-3.0[${PYTHON_USEDEP}]
+       <dev-python/uritemplate-4[${PYTHON_USEDEP}]
+       >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+       <dev-python/six-2[${PYTHON_USEDEP}]
+       "
+DEPEND="${RDEPEND}
+       test? (
+               dev-python/google-auth-httplib2[${PYTHON_USEDEP}]
+               dev-python/unittest2[${PYTHON_USEDEP}]
+       )"
+
+PATCHES=(
+       "${FILESDIR}/google-api-python-client-1.8.3-tests.patch"
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+       distutils_install_for_testing
+       pytest -vv || die "tests fail with ${EPYTHON}"
+}