dev-python/imexam: remove last-rited pkg
authorMikle Kolyada <zlogene@gentoo.org>
Sat, 28 Dec 2019 16:54:47 +0000 (19:54 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sat, 28 Dec 2019 16:54:47 +0000 (19:54 +0300)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
dev-python/imexam/Manifest [deleted file]
dev-python/imexam/files/imexam-0.7.1-system-xpa.patch [deleted file]
dev-python/imexam/imexam-0.7.1.ebuild [deleted file]
dev-python/imexam/metadata.xml [deleted file]

diff --git a/dev-python/imexam/Manifest b/dev-python/imexam/Manifest
deleted file mode 100644 (file)
index f0c97ae..0000000
+++ /dev/null
@@ -1 +0,0 @@
-DIST imexam-0.7.1.tar.gz 20264259 BLAKE2B 0cda1ca386997b0e98d47af47a549993fe4d23b4d5e7a7620b1077adc7d51301009a5c57a7a79776ee15a8efeb572a8b1628d7b21a8b404a94f53ae525ca8a16 SHA512 cb09d1764de19333fa6be1bbb9e6efd3d59943fdef4ccac4e8429e436dd615fa5be3a06c9473cc2c3ff1de1a8987d02ef24765de5b36131c31451b013be8d776
diff --git a/dev-python/imexam/files/imexam-0.7.1-system-xpa.patch b/dev-python/imexam/files/imexam-0.7.1-system-xpa.patch
deleted file mode 100644 (file)
index fc90ffe..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-From: Ole Streicher <ole@aip.de>
-Date: Fri, 21 Apr 2017 13:40:06 +0200
-Subject: Use external xpa
-
----
- setup.py | 15 +++------------
- 1 file changed, 3 insertions(+), 12 deletions(-)
-
-diff --git a/setup.py b/setup.py
-index f0dd5d5..f291201 100644
---- a/setup.py
-+++ b/setup.py
-@@ -121,24 +121,20 @@ if not sys.platform.startswith('win'):
-                    xpaio.c
-                    """.split()
--    XPA_SOURCES = [os.path.join(XPALIB_DIR, c) for c in XPA_FILES]
--    XPALIB_DEFINES = [("HAVE_CONFIG_H", "1")]
-+    XPA_SOURCES = []
-+    XPALIB_DEFINES = []
-     XPA_SOURCES.append(CYTHON_SOURCE)
-     xpa_module = Extension("xpa",
-                            sources=XPA_SOURCES,
--                           include_dirs=[XPALIB_DIR],
-                            define_macros=XPALIB_DEFINES,
--                           depends=[CONF_H_NAME],
-+                           libraries = ['xpa'],
-                            )
-     if use_cython:
-         ext = cythonize(xpa_module)
-         class my_clean(clean):
-             def run(self):
--                import subprocess
--                subprocess.call(["make", "clean"],
--                                cwd=XPALIB_DIR)
-                 if os.access(CONF_H_NAME, os.F_OK):
-                     os.remove(CONF_H_NAME)
-                 os.remove("wrappers/xpa.c")
-@@ -147,11 +143,6 @@ if not sys.platform.startswith('win'):
-         class build_ext_with_configure(build_ext):
-             def build_extensions(self):
--                import subprocess
--                subprocess.call(["make", "-f", "Makefile", "clean"],
--                                cwd=XPALIB_DIR)
--                subprocess.call(["sh", "./configure"], cwd=XPALIB_DIR)
--                subprocess.call(["make", "-f", "Makefile"], cwd=XPALIB_DIR)
-                 build_ext.build_extensions(self)
-         cmdclass.update({'build_ext': build_ext_with_configure,
diff --git a/dev-python/imexam/imexam-0.7.1.ebuild b/dev-python/imexam/imexam-0.7.1.ebuild
deleted file mode 100644 (file)
index 409dcc6..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{5,6} )
-
-inherit distutils-r1 xdg-utils
-
-DESCRIPTION="Simple interactive astronomical image examination and plotting"
-HOMEPAGE="https://imexam.readthedocs.io"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/astropy[${PYTHON_USEDEP}]
-       dev-python/ginga[${PYTHON_USEDEP}]
-       dev-python/ipython[${PYTHON_USEDEP}]
-       dev-python/matplotlib[${PYTHON_USEDEP}]
-       sci-libs/scipy[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/astropy-helpers[${PYTHON_USEDEP}]
-       dev-python/cython[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}"/${P}-system-xpa.patch )
-
-python_prepare_all() {
-       # use system astropy-helpers instead of bundled one
-       sed -i -e '/auto_use/s/True/False/' setup.cfg || die
-       echo "backend: Agg" > "${T}"/matplotlibrc || die
-       xdg_environment_reset
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc; then
-               python_setup
-               VARTEXFONTS="${T}"/fonts \
-                       MPLCONFIGDIR="${T}" \
-                       PYTHONPATH="${BUILD_DIR}"/lib \
-                       esetup.py build_docs --no-intersphinx
-               HTML_DOCS=( docs/_build/html/. )
-       fi
-}
-
-python_test() {
-       esetup.py test -v
-}
diff --git a/dev-python/imexam/metadata.xml b/dev-python/imexam/metadata.xml
deleted file mode 100644 (file)
index 6a478af..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-  <maintainer type="project">
-    <email>sci-astronomy@gentoo.org</email>
-    <name>Gentoo Astronomy Project</name>
-  </maintainer>
-  <longdescription lang="en">
- Imexam is an affiliated package of AstroPy. It was designed to be a
- lightweight library which enables users to explore data using common
- methods which are consistent across viewers. It can be used from a
- command line interface, through a Jupyter notebook or through a
- Jupyter console. It can be used with multiple viewers, such as DS9 or
- Ginga, or without a viewer as a simple library to make plots and grab
- quick photometry information.
-  </longdescription>
-  <upstream>
-    <remote-id type="pypi">imexam</remote-id>
-    <remote-id type="github">spacetelescope/imexam</remote-id>
-  </upstream>
-</pkgmetadata>