dev-python/nose: Update the twisted test dependency, switch order
authorBrian Dolbec <dolsen@gentoo.org>
Tue, 4 Apr 2017 23:59:18 +0000 (16:59 -0700)
committerBrian Dolbec <dolsen@gentoo.org>
Wed, 5 Apr 2017 00:02:30 +0000 (17:02 -0700)
Switch the order to prefer the single pkg twisted.
Update it for all PYTHON_COMPAT targets available.
Change the split twisted dep for the single twisted in the 9999.

Package-Manager: Portage-2.3.5, Repoman-2.3.2_p30

dev-python/nose/nose-1.3.7-r3.ebuild
dev-python/nose/nose-9999.ebuild

index e58e73ded7d2337f7b274637c3a0b97e19ec497b..2a7bb6ef38cf0fa5f1fc157cc10299a74a0248b6 100644 (file)
@@ -28,8 +28,9 @@ RDEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
        doc? ( >=dev-python/sphinx-0.6[${PYTHON_USEDEP}] )
-       test? ( || ( $(python_gen_cond_dep 'dev-python/twisted-core[${PYTHON_USEDEP}]' python2_7)
-                $(python_gen_cond_dep 'dev-python/twisted[${PYTHON_USEDEP}]' python2_7) ) )"
+       test? ( || ( $(python_gen_cond_dep 'dev-python/twisted[${PYTHON_USEDEP}]' python2_7 python3_{4,5,6})
+                       $(python_gen_cond_dep 'dev-python/twisted-core[${PYTHON_USEDEP}]' python2_7)
+                ) )"
 
 PATCHES=(
        "${FILESDIR}"/${P}-python-3.5-backport.patch
index 1b37a07fb934a3777279c99bfb51efa04004a5a7..132633f36b15b09a515560201ca6fde832b9fc30 100644 (file)
@@ -31,7 +31,7 @@ RDEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
        doc? ( >=dev-python/sphinx-0.6[${PYTHON_USEDEP}] )
-       test? ( $(python_gen_cond_dep 'dev-python/twisted-core[${PYTHON_USEDEP}]' python2_7) )"
+       test? ( $(python_gen_cond_dep 'dev-python/twisted[${PYTHON_USEDEP}]' python2_7 python3_{4,5,6}) )"
 
 pkg_setup() {
        use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )