projects
/
portage.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
f421c2d
)
Bug #97776 - Tell rpmbuild to clean it's working files after completion.
author
Zac Medico
<zmedico@gentoo.org>
Fri, 28 Mar 2008 11:44:39 +0000
(11:44 -0000)
committer
Zac Medico
<zmedico@gentoo.org>
Fri, 28 Mar 2008 11:44:39 +0000
(11:44 -0000)
(trunk r9428)
svn path=/main/branches/2.1.2/; revision=9547
bin/misc-functions.sh
patch
|
blob
|
history
diff --git
a/bin/misc-functions.sh
b/bin/misc-functions.sh
index 680c5b1856ec801a412bf10004579cb0140ab8a1..d38c9a14fa9af0ac3c6a062a4d441f9503fbc045 100755
(executable)
--- a/
bin/misc-functions.sh
+++ b/
bin/misc-functions.sh
@@
-598,7
+598,7
@@
dyn_rpm() {
addwrite /usr/src/rpm
addwrite "${RPMDIR}"
dyn_spec
- rpmbuild -bb "${PF}.spec" || die "Failed to integrate rpm spec file"
+ rpmbuild -bb
--clean --rmsource
"${PF}.spec" || die "Failed to integrate rpm spec file"
install -D "/usr/src/rpm/RPMS/i386/${PN}-${PV}-${PR}.i386.rpm" \
"${RPMDIR}/${CATEGORY}/${PN}-${PV}-${PR}.rpm" || \
die "Failed to move rpm"