Version bump
authorDon Seiler <rizzo@gentoo.org>
Fri, 25 Jun 2004 03:44:36 +0000 (03:44 +0000)
committerDon Seiler <rizzo@gentoo.org>
Fri, 25 Jun 2004 03:44:36 +0000 (03:44 +0000)
net-im/gaim-encryption/ChangeLog
net-im/gaim-encryption/files/digest-gaim-encryption-2.27 [new file with mode: 0644]
net-im/gaim-encryption/gaim-encryption-2.27.ebuild [new file with mode: 0644]

index b58813625cef24e32262c4e7d7a90dad7a4f844e..ce6d5db2a95be2d27660f8641a1f9c589e90c34f 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for net-im/gaim-encryption
 # Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim-encryption/ChangeLog,v 1.32 2004/06/24 22:51:34 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim-encryption/ChangeLog,v 1.33 2004/06/25 03:44:36 rizzo Exp $
+
+*gaim-encryption-2.27 (24 Jun 2004)
+
+  24 Jun 2004; Don Seiler <rizzo@gentoo.org> +gaim-encryption-2.27.ebuild:
+  Version bump.
 
   01 Jun 2004; Aron Griffis <agriffis@gentoo.org> gaim-encryption-2.25.ebuild:
   stable on ia64
diff --git a/net-im/gaim-encryption/files/digest-gaim-encryption-2.27 b/net-im/gaim-encryption/files/digest-gaim-encryption-2.27
new file mode 100644 (file)
index 0000000..2453409
--- /dev/null
@@ -0,0 +1 @@
+MD5 b5d24bbada652d9673f35c5f3c6b03c7 gaim-encryption-2.27.tar.gz 363114
diff --git a/net-im/gaim-encryption/gaim-encryption-2.27.ebuild b/net-im/gaim-encryption/gaim-encryption-2.27.ebuild
new file mode 100644 (file)
index 0000000..9d9085c
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim-encryption/gaim-encryption-2.27.ebuild,v 1.1 2004/06/25 03:44:36 rizzo Exp $
+
+inherit flag-o-matic eutils
+use debug && inherit debug
+
+DESCRIPTION="GAIM Encryption PlugIn"
+HOMEPAGE="http://gaim-encryption.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc ~alpha ~ia64 ~hppa ~mips"
+IUSE="debug"
+
+DEPEND="~net-im/gaim-0.79
+               dev-libs/nss"
+
+src_compile() {
+       local myconf
+
+       NSS_LIB=/usr/lib
+       NSS_INC=/usr/include
+       myconf="${myconf} --with-nspr-includes=${NSS_INC}/nspr"
+       myconf="${myconf} --with-nss-includes=${NSS_INC}/nss"
+       myconf="${myconf} --with-nspr-libs=${NSS_LIB}"
+       myconf="${myconf} --with-nss-libs=${NSS_LIB}"
+
+       econf ${myconf} || die "Configuration failed"
+       einfo "Replacing -Os CFLAG with -O2"
+       replace-flags -Os -O2
+
+       emake || emake -j1 || die "Make failed"
+}
+
+src_install() {
+       einstall || die "Install failed"
+       dodoc CHANGELOG COPYING INSTALL NOTES README TODO VERSION WISHLIST
+}
+