dev-python/pyprof2calltree: 1.4.4 + EAPI 7 + py3[78]
authorSebastian Pipping <sping@gentoo.org>
Thu, 19 Mar 2020 03:20:37 +0000 (04:20 +0100)
committerSebastian Pipping <sping@gentoo.org>
Thu, 19 Mar 2020 03:22:37 +0000 (04:22 +0100)
Bug: https://bugs.gentoo.org/711808
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.92, Repoman-2.3.20

dev-python/pyprof2calltree/Manifest
dev-python/pyprof2calltree/pyprof2calltree-1.4.4.ebuild [new file with mode: 0644]
profiles/package.mask

index ddf94826fa4c6e197bf00af1a30ce41bf3a0ed59..260a36b16fe42bcf435052e79035e4b2c8e662f7 100644 (file)
@@ -1 +1,2 @@
 DIST pyprof2calltree-1.4.0.tar.gz 7784 BLAKE2B e8b9ecd857930406bb3b7f7851913a68f1e3433f3b42c262922b5d5b0fbfa692078fdad811d4ca358f7c74d14320c914cfa779ed0b9da8c4fcd7d8e021fd3319 SHA512 b1acba29cd4e5112012eeeffdac53900688a28707306ef3a8a3827f7422c35bc921d59d33db3209db923bb8640014e7d9d7d819eafbcb19e0cf7e6159537bded
+DIST pyprof2calltree-1.4.4.tar.gz 8797 BLAKE2B 0929728d3a6de1cc40e54bd4581bb4b64875a4d7f3ccef725300d40d2b3fd175d8ff462591357e32a471e5c3a4c5c51ac7e9c81c2e857050745a748bc4117d8a SHA512 7ffc228e542a568cb421394035660623415495472b5b3659a35b02c7ccccb7f578dc872d2bb1daf4fdfcd44134e1ad9b5ce3a18f49b15dd4aeb3b5f1201a28d8
diff --git a/dev-python/pyprof2calltree/pyprof2calltree-1.4.4.ebuild b/dev-python/pyprof2calltree/pyprof2calltree-1.4.4.ebuild
new file mode 100644 (file)
index 0000000..e4a9af8
--- /dev/null
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="convert python profile data to kcachegrind calltree form"
+HOMEPAGE="https://pypi.org/project/pyprof2calltree/"
+# pypi tarball lacks tests
+SRC_URI="https://github.com/pwaller/pyprof2calltree/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests setup.py
index 36148d9201735679896ac8751f2918883cd45882..00570fb1c5d767f92661edc7cded1ce915bcd390 100644 (file)
@@ -238,7 +238,6 @@ dev-python/pyhcl
 dev-python/pymtp
 dev-python/pynzb
 dev-python/pyopencl
-dev-python/pyprof2calltree
 dev-python/pyshark
 dev-python/pysnmp-apps
 dev-python/pysnmp-mibs