dev-lua/penlight: version bump to 1.7.0
authorVictor Payno <vpayno+gentoo@gmail.com>
Mon, 2 Mar 2020 21:16:45 +0000 (13:16 -0800)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Mon, 16 Mar 2020 00:11:56 +0000 (17:11 -0700)
Closes: https://github.com/gentoo/gentoo/pull/14440
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-lua/penlight/Manifest
dev-lua/penlight/metadata.xml
dev-lua/penlight/penlight-1.7.0.ebuild [new file with mode: 0644]

index f6cca28a8e059b57843faf031ca05726ac96523b..d348b03ca14231208f89ede6df740586b179172a 100644 (file)
@@ -1,2 +1,3 @@
 DIST penlight-1.3.2-core.zip 116854 BLAKE2B c653a51cf8ea286c849e1a2c68968ed767c350b1461dd11d9a2e99c81295461c67044175c7bf99c31e8040118e6cfce85f8613d4b6c49e726d31393029abcbbf SHA512 01ba35e967e255f6f39afff9c2238f4921de9e52850ce0d2ec0c9068029fc61a241c82bede680a28fda46c4504582784fcd2241a2eef0bef95c7c389c4042d02
 DIST penlight-1.5.4.tar.gz 213938 BLAKE2B c6bba4fd7fc491d2e6ca464f71b897ba4b5dc8dc94e7340fd77d3add47a9b4a72ce48cea268f94fe55c2aef1edd850f96f00f2ba1ef7186e1e8d86a4e3155366 SHA512 c46e7875410a90390bfbf010a53f1d536475e2094668722618d03951caad0fcb0674c9bc7119a0753e4ed3df9e4d70fef828ba4c6c24e8ada4036948d2432519
+DIST penlight-1.7.0.tar.gz 384917 BLAKE2B 153660f5029509611265399aad8b92d82b266ac470414c06e9d7f01b37225834f98488f30f9bbdfdc3a6714edfe2edc0fccd0356ebb966d964be633bff38eb25 SHA512 edeb09307c9feb5da6bccd82216a6ad71db988c433245d72d28abb6c555004f77eebba556928b0912937b29ef93e065ad491368041e17730610813de8e595d7d
index 8fc3b6a3bf44b9df105dbf2b3fc45fd8a6e57d57..2d40d2a40111a2debf0d8b94d6af24ed9c3279aa 100644 (file)
@@ -11,4 +11,7 @@
                configuration files and the like. Provides functional operations
                on tables and sequences.
        </longdescription>
+       <upstream>
+               <remote-id type="github">Tieske/Penlight</remote-id>
+       </upstream>
 </pkgmetadata>
diff --git a/dev-lua/penlight/penlight-1.7.0.ebuild b/dev-lua/penlight/penlight-1.7.0.ebuild
new file mode 100644 (file)
index 0000000..1036bea
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lua utility libraries loosely based on the Python standard libraries"
+HOMEPAGE="https://github.com/Tieske/Penlight",
+SRC_URI="https://github.com/Tieske/Penlight/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND=">=dev-lang/lua-5.1:=
+       dev-lua/luafilesystem"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN//penlight/Penlight}-${PV}"
+
+src_install() {
+       local -a DOCS=( README.md CHANGELOG.md LICENSE.md CONTRIBUTING.md )
+       einstalldocs
+
+       insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
+       doins -r lua/pl
+}