games-emulation/generator: tweak for gcc-9
authorSergei Trofimovich <slyfox@gentoo.org>
Thu, 31 Oct 2019 07:52:07 +0000 (07:52 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 31 Oct 2019 07:52:19 +0000 (07:52 +0000)
Fixed-by: kleph
Closes: https://bugs.gentoo.org/698944
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
games-emulation/generator/files/generator-0.35_p4-gcc-9.patch [new file with mode: 0644]
games-emulation/generator/generator-0.35_p4-r1.ebuild

diff --git a/games-emulation/generator/files/generator-0.35_p4-gcc-9.patch b/games-emulation/generator/files/generator-0.35_p4-gcc-9.patch
new file mode 100644 (file)
index 0000000..7b8eeaf
--- /dev/null
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/698944
+
+--- a/main/vdp.c
++++ b/main/vdp.c
+@@ -87,7 +87,7 @@ void vdp_describe(void);
+ void vdp_eventinit(void);
+ void vdp_layer_simple(unsigned int layer, unsigned int priority,
+                       uint8 *fielddata, unsigned int lineoffset);
+-inline void vdp_plotcell(uint8 *patloc, uint8 palette, uint8 flags,
++static void vdp_plotcell(uint8 *patloc, uint8 palette, uint8 flags,
+                          uint8 *cellloc, unsigned int lineoffset);
+ void vdp_sprites(unsigned int line, uint8 *pridata, uint8 *outdata);
+ int vdp_sprite_simple(unsigned int priority, uint8 *framedata,
+@@ -1733,7 +1733,7 @@ void vdp_endfield(void)
+      vdp_event_endline); */
+ }
+-inline void vdp_plotcell(uint8 *patloc, uint8 palette, uint8 flags,
++static void vdp_plotcell(uint8 *patloc, uint8 palette, uint8 flags,
+                          uint8 *cellloc, unsigned int lineoffset)
+ {
+   int y, x;
index 3c6fe06f5de10c54da699d8cbc1204e360581a72..54614d750d7842780e2c5e0faa9981ae53db73f9 100644 (file)
@@ -23,12 +23,15 @@ RDEPEND="${DEPEND}"
 
 S="${WORKDIR}/${MY_P}"
 
+PATCHES=(
+       "${FILESDIR}"/${P}-configure.patch
+       "${FILESDIR}"/${P}-underlink.patch
+       "${FILESDIR}"/${P}-inline.patch
+       "${FILESDIR}"/${P}-gcc-9.patch
+)
+
 src_prepare() {
        default
-       eapply \
-               "${FILESDIR}"/${P}-configure.patch \
-               "${FILESDIR}"/${P}-underlink.patch \
-               "${FILESDIR}"/${P}-inline.patch
 
        sed -i -e 's/@GTK_CFLAGS@//g' main/Makefile.am || die
        eautoreconf
@@ -43,11 +46,6 @@ src_configure() {
                $(use_with sdlaudio sdl-audio)
 }
 
-src_compile() {
-       [[ -f Makefile ]] && emake clean
-       emake -j1
-}
-
 src_install() {
        dobin main/generator-sdl
        dodoc AUTHORS ChangeLog NEWS README TODO docs/*