dev-python/statsd: Add missing test dep, py3.8, modernize
authorMichał Górny <mgorny@gentoo.org>
Fri, 1 May 2020 14:50:51 +0000 (16:50 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 1 May 2020 15:44:01 +0000 (17:44 +0200)
Closes: https://bugs.gentoo.org/720096
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/statsd/statsd-3.3.0.ebuild

index f92fe942f384b19a86a5bd3f1c5c831c59124610..cd01b37d821de6e3cfe151a7f74757fc603e0a9c 100644 (file)
@@ -2,28 +2,21 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python3_{6,7} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
 
 inherit distutils-r1
 
 DESCRIPTION="A simple statsd client"
 HOMEPAGE="https://github.com/jsocol/pystatsd https://pypi.org/project/statsd"
-
 SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
 
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
 
-RDEPEND=""
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
        test? (
-               dev-python/nose[${PYTHON_USEDEP}]
+               dev-python/mock[${PYTHON_USEDEP}]
        )"
 
-python_test() {
-       nosetests --verbose || die
-}
+distutils_enable_tests nose