net-p2p/fms: Version bump
authorThomas Sachau <tommy@gentoo.org>
Wed, 18 Mar 2020 18:01:01 +0000 (19:01 +0100)
committerThomas Sachau <tommy@gentoo.org>
Wed, 18 Mar 2020 18:01:01 +0000 (19:01 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: Thomas Sachau <tommy@gentoo.org>
net-p2p/fms/Manifest
net-p2p/fms/fms-0.3.82.ebuild [new file with mode: 0644]

index d1d553de60791a586ef24be83866d3d237ede205..bed5c3d4041f310b400df5574b971eca7b523914 100644 (file)
@@ -1,2 +1,3 @@
 DIST fms-src-0.3.80.zip 4583891 BLAKE2B 363fe148c622d999398d2f435f49e312d3bea22ad6b69865a618593616b47b632c1a56bcc8fc75bd40590e3858aad7e3f1d70991a21936e38562e10f1813b49c SHA512 d3aa5eb7d417bb135d88a515702fac9c451054d071374bb7f475add9af7e1fda90f4d9c61569e3e9040b2a241efa7fcc7ecac32a7f652327d15ed8d1ea1418c4
 DIST fms-src-0.3.81.zip 4732577 BLAKE2B a873fe4458a4abf4d19c7849d2045e49f556e001315d9112f50fd5c544481c64e00d0db5672ca20f1974e8d8b46e88b98e6a339536659a8a4c06b1a3c4439d21 SHA512 7e5efc2bf22fd3ba24d61fb4a7afbd3b6181a6ea4d038bc06bc2135dd9254835647cbb62be68982ee553212be9f2e038f50623916db3131b2fd19a77c3180af2
+DIST fms-src-0.3.82.zip 4786920 BLAKE2B c18630b8b1b8871290f1d66c4638b99c110e0f49bef11517aa83760274707fd5d0b53c053ea3b38a0c35018de4a4b6f3dd426499228997bac377bb1f04f784fb SHA512 2a72cbc7e23eb16cc12bd373944d1da090030602a09d0c1cf2fd8688a7b1a98ff649f1d0aa8b525b65987394d81acbb9b7558fcb21cea90a7646067a16600673
diff --git a/net-p2p/fms/fms-0.3.82.ebuild b/net-p2p/fms/fms-0.3.82.ebuild
new file mode 100644 (file)
index 0000000..574d26f
--- /dev/null
@@ -0,0 +1,77 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils cmake-utils user
+
+DESCRIPTION="A spam-resistant message board application for Freenet"
+#FMS oly has a homepage within freenet, so the closest is a wiki linking to it
+HOMEPAGE="https://github.com/freenet/wiki/wiki/FMS"
+SRC_URI="https://dev.gentoo.org/~tommy/distfiles/${PN}-src-${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="frost ssl"
+
+RDEPEND="virtual/libiconv
+       frost? ( net-libs/mbedtls )
+       ssl? ( net-libs/mbedtls )
+       >=dev-libs/poco-1.4.3_p1
+       >=dev-db/sqlite-3.6.15"
+DEPEND="${RDEPEND}
+       app-arch/unzip"
+
+S=${WORKDIR}
+PATCHES=( "${FILESDIR}"/${PN}-use-system-libs4.patch )
+
+pkg_setup() {
+       enewgroup freenet
+       enewuser freenet -1 -1 /var/freenet freenet
+}
+
+src_prepare() {
+       rm -rv  libs
+       edos2unix src/http/pages/showfilepage.cpp
+       edos2unix CMakeLists.txt
+
+       cmake-utils_src_prepare
+}
+
+src_configure() {
+       local mycmakeargs=( -DI_HAVE_READ_THE_README=ON \
+               -DUSE_BUNDLED_SQLITE=OFF \
+               -DDO_CHARSET_CONVERSION=ON \
+               -DFROST_SUPPORT=$(use frost && echo ON || echo OFF) \
+               -DFCP_SSL_SUPPORT=$(use ssl && echo ON || echo OFF) )
+       cmake-utils_src_configure
+}
+
+src_install() {
+       insinto /var/freenet/fms
+       dobin "${CMAKE_BUILD_DIR}"/fms || die
+       doins *.htm || die "doinstall failed"
+       doins -r fonts images styles translations || die
+       fperms -R o-rwx /var/freenet/fms/ /usr/bin/fms
+       fowners -R freenet:freenet /var/freenet/fms/ /usr/bin/fms
+       doinitd "${FILESDIR}/fms" || die "installing init.d file failed"
+       dodoc readme.txt || die "installing doc failed"
+}
+
+pkg_postinst() {
+       if ! has_version 'net-p2p/freenet' ; then
+               ewarn "FMS needs a freenet node to up-/download messages."
+               ewarn "Please make sure to have a node you can connect to"
+               ewarn "or install net-p2p/freenet to get FMS working."
+       fi
+       elog "By default, the FMS NNTP server will listen on port 1119,"
+       elog "and the web configuration interface will be running at"
+       elog "http://localhost:8080. For more information, read"
+       elog "${ROOT}usr/share/doc/${PF}/readme.txt.bz2"
+       if use frost; then
+               elog " "
+               elog "You need to enable frost on the config page"
+               elog "and restart fms for frost support."
+       fi
+}