app-misc/chkcrontab: new package, crontab lint
authorTomas Mozes <hydrapolic@gmail.com>
Mon, 4 Jan 2016 12:01:44 +0000 (13:01 +0100)
committerIan Delaney <idella4@gentoo.org>
Mon, 4 Jan 2016 13:31:12 +0000 (21:31 +0800)
Package-Manager: portage-2.2.26

app-misc/chkcrontab/Manifest [new file with mode: 0644]
app-misc/chkcrontab/chkcrontab-1.6.ebuild [new file with mode: 0644]
app-misc/chkcrontab/metadata.xml [new file with mode: 0644]

diff --git a/app-misc/chkcrontab/Manifest b/app-misc/chkcrontab/Manifest
new file mode 100644 (file)
index 0000000..9456297
--- /dev/null
@@ -0,0 +1 @@
+DIST chkcrontab-1.6.tar.gz 24701 SHA256 be7436d5ece4ad6390365f6edf0f1dc59dfd655a9de3b4699884343ceb150f2e SHA512 249061ecf7c8dc2d2275dcda3048fd00fc2ca85d39dabb2de61a3ab415243bbd1a61222be8c0ddfa66eb36577bb2efb27ba4a0c2a013559dee126c95cc73bd1b WHIRLPOOL 13995293e761930d0d900c3e7fa5b7695fad3416ade96fc34be415a448ca5e5969f5b82889d46041ed801ca2f13e5154a01698d753898ee9027bd9a2c8e6e29f
diff --git a/app-misc/chkcrontab/chkcrontab-1.6.ebuild b/app-misc/chkcrontab/chkcrontab-1.6.ebuild
new file mode 100644 (file)
index 0000000..7e27c3f
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool to detect crontab errors"
+HOMEPAGE="https://github.com/lyda/chkcrontab"
+SRC_URI="https://github.com/lyda/chkcrontab/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+python_test() {
+       esetup.py test
+}
+
+python_install_all() {
+       doman doc/${PN}.1
+       distutils-r1_python_install_all
+}
diff --git a/app-misc/chkcrontab/metadata.xml b/app-misc/chkcrontab/metadata.xml
new file mode 100644 (file)
index 0000000..d8aa7d5
--- /dev/null
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <herd>proxy-maintainers</herd>
+       <maintainer>
+               <email>hydrapolic@gmail.com</email>
+               <name>Tomas Mozes</name>
+               <description>Proxy maintainer</description>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">lyda/chkcrontab</remote-id>
+       </upstream>
+</pkgmetadata>