media-plugins/kodi-game-libretro-snes9x: 1.58.0.6 version bump
authorCraig Andrews <candrews@gentoo.org>
Tue, 2 Jul 2019 21:04:58 +0000 (17:04 -0400)
committerCraig Andrews <candrews@gentoo.org>
Tue, 2 Jul 2019 21:16:29 +0000 (17:16 -0400)
Bug: https://bugs.gentoo.org/688474
Package-Manager: Portage-2.3.68, Repoman-2.3.16
Signed-off-by: Craig Andrews <candrews@gentoo.org>
media-plugins/kodi-game-libretro-snes9x/Manifest [new file with mode: 0644]
media-plugins/kodi-game-libretro-snes9x/kodi-game-libretro-snes9x-1.58.0.6.ebuild [new file with mode: 0644]
media-plugins/kodi-game-libretro-snes9x/kodi-game-libretro-snes9x-9999.ebuild

diff --git a/media-plugins/kodi-game-libretro-snes9x/Manifest b/media-plugins/kodi-game-libretro-snes9x/Manifest
new file mode 100644 (file)
index 0000000..1ca8085
--- /dev/null
@@ -0,0 +1 @@
+DIST kodi-game-libretro-snes9x-1.58.0.6.tar.gz 1373392 BLAKE2B 6d17ac222eeae8e23aa76ab0b1aafe805f260b14c210715275afb370c2c52381013b48805477d01389fa1067e14f24465f35449dd95e309dfec7ac93b090df72 SHA512 3cc3b5eda830223a447dda4efb0438db679222200cae07d59f0879f95b1d252972186a241a74d0fa4668697a4ef8d2860923a43c7f4223af4ce794e937f255aa
diff --git a/media-plugins/kodi-game-libretro-snes9x/kodi-game-libretro-snes9x-1.58.0.6.ebuild b/media-plugins/kodi-game-libretro-snes9x/kodi-game-libretro-snes9x-1.58.0.6.ebuild
new file mode 100644 (file)
index 0000000..de40670
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Snes9x GameClient for Kodi"
+HOMEPAGE="https://github.com/kodi-game/game.libretro.snes9x"
+SRC_URI=""
+
+if [[ ${PV} == *9999 ]]; then
+       SRC_URI=""
+       EGIT_REPO_URI="https://github.com/kodi-game/game.libretro.snes9x.git"
+       inherit git-r3
+else
+       KEYWORDS="~amd64 ~x86"
+       CODENAME="Leia"
+       SRC_URI="https://github.com/kodi-game/game.libretro.snes9x/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+       S="${WORKDIR}/game.libretro.snes9x-${PV}-${CODENAME}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+       =media-tv/kodi-18*
+       games-emulation/libretro-snes9x
+       "
+RDEPEND="
+       media-plugins/kodi-game-libretro
+       ${DEPEND}
+       "
+src_prepare() {
+       echo 'find_library(SNES9X_LIB NAMES snes9x_libretro${CMAKE_SHARED_LIBRARY_SUFFIX} PATH_SUFFIXES libretro)' > "${S}/Findlibretro-snes9x.cmake" || die
+       default
+}
index a3c02f28e235d0a3bdecb67e913260de499b2026..7dee71b48dd0b182f6e50ad9569a0d686de664ac 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -15,8 +15,9 @@ if [[ ${PV} == *9999 ]]; then
        inherit git-r3
 else
        KEYWORDS="~amd64 ~x86"
-       SRC_URI="https://github.com/kodi-game/game.libretro.snes9x/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-       S="${WORKDIR}/game.libretro.snes9x-${PV}"
+       CODENAME="Leia"
+       SRC_URI="https://github.com/kodi-game/game.libretro.snes9x/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+       S="${WORKDIR}/game.libretro.snes9x-${PV}-${CODENAME}"
 fi
 
 LICENSE="GPL-2"