net-firewall/ufw: drop old 0.34.
authorHasan ÇALIŞIR <hasan.calisir@psauxit.com>
Tue, 13 Aug 2019 14:44:21 +0000 (17:44 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 13 Aug 2019 16:52:52 +0000 (19:52 +0300)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Hasan ÇALIŞIR <hasan.calisir@psauxit.com>
Closes: https://github.com/gentoo/gentoo/pull/12694
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-firewall/ufw/Manifest
net-firewall/ufw/ufw-0.34_pre805-r2.ebuild [deleted file]

index ad31ad0661ae5d157447f725db849c3e5651d7fa..4a7bb64fd2590e1010c533584fe5fdbf8814f138 100644 (file)
@@ -1,3 +1,2 @@
-DIST ufw-0.34_pre805.tar.gz 335875 BLAKE2B a2b654fe35a299ffd9978ef14a8d5667f799b654b6285bc81756c8081d9f4417b2fa9c05a234351d42709c2c57ff624b4fe7bca8ffe4d13cd12436feead6e4da SHA512 b8bba3bb8c423070d6434d1df7274423edf3a356415f54c6448fa0ff2d13a4b2ac21c4bb627cba01d6955b04f793eeaf2fc535c6221e7de48f11bef745035263
 DIST ufw-0.35.tar.gz 375310 BLAKE2B 3babf22e860ead6970c1386b0ab9fc3de364ba3f5c8bc0237be4a9446358fe058d216e7928d16eed8a148fbee5b82fc1d9e3b358f357c2fac236ae6f6b942a01 SHA512 b36c82559910634505648f717d19eb5a0cb1ce739a804359087e74c966869d0375c4ed5811954b32d2b5b51866f6ae1bec62a4a464f226b2eecc56b096f303fc
 DIST ufw-0.36.tar.gz 580338 BLAKE2B a7e07ac11539061a69bb83d45c0affc54793503b31c9e9f9f8b34fa890a3fe97682f9133102e74e5f6e1eb372a929cfc8619baa2cc9efc1dc289d9f4a1766efd SHA512 b32d7f79f43c203149c48b090ee0d063df78fcf654344ee11066a7363e799a62b046758ffe02b8bd15121545ac2a6b61df21fe56f8b810319fe4dd562cbdadb3
diff --git a/net-firewall/ufw/ufw-0.34_pre805-r2.ebuild b/net-firewall/ufw/ufw-0.34_pre805-r2.ebuild
deleted file mode 100644 (file)
index 73f230e..0000000
+++ /dev/null
@@ -1,185 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-DISTUTILS_IN_SOURCE_BUILD=1
-
-inherit bash-completion-r1 eutils linux-info distutils-r1 systemd
-
-DESCRIPTION="A program used to manage a netfilter firewall"
-HOMEPAGE="https://launchpad.net/ufw"
-SRC_URI="mirror://sabayon/${CATEGORY}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ia64 ppc ppc64 sparc ~x86"
-IUSE="examples ipv6"
-
-DEPEND="sys-devel/gettext"
-RDEPEND=">=net-firewall/iptables-1.4[ipv6?]
-       !<kde-misc/kcm-ufw-0.4.2
-       !<net-firewall/ufw-frontends-0.3.2
-"
-
-# tests fail; upstream bug: https://bugs.launchpad.net/ufw/+bug/815982
-RESTRICT="test"
-
-PATCHES=(
-       # Remove unnecessary build time dependency on net-firewall/iptables.
-       "${FILESDIR}"/${PN}-0.33-dont-check-iptables.patch
-       # Move files away from /lib/ufw.
-       "${FILESDIR}"/${PN}-0.31.1-move-path.patch
-       # Remove shebang modification.
-       "${FILESDIR}"/${P}-shebang.patch
-       # Fix bash completions, bug #526300
-       "${FILESDIR}"/${P}-bash-completion.patch
-)
-
-pkg_pretend() {
-       local CONFIG_CHECK="~PROC_FS
-               ~NETFILTER_XT_MATCH_COMMENT ~NETFILTER_XT_MATCH_HL
-               ~NETFILTER_XT_MATCH_LIMIT ~NETFILTER_XT_MATCH_MULTIPORT
-               ~NETFILTER_XT_MATCH_RECENT ~NETFILTER_XT_MATCH_STATE"
-
-       if kernel_is -ge 2 6 39; then
-               CONFIG_CHECK+=" ~NETFILTER_XT_MATCH_ADDRTYPE"
-       else
-               CONFIG_CHECK+=" ~IP_NF_MATCH_ADDRTYPE"
-       fi
-
-       # https://bugs.launchpad.net/ufw/+bug/1076050
-       if kernel_is -ge 3 4; then
-               CONFIG_CHECK+=" ~NETFILTER_XT_TARGET_LOG"
-       else
-               CONFIG_CHECK+=" ~IP_NF_TARGET_LOG"
-               use ipv6 && CONFIG_CHECK+=" ~IP6_NF_TARGET_LOG"
-       fi
-
-       CONFIG_CHECK+=" ~IP_NF_TARGET_REJECT"
-       use ipv6 && CONFIG_CHECK+=" ~IP6_NF_TARGET_REJECT"
-
-       check_extra_config
-
-       # Check for default, useful optional features.
-       if ! linux_config_exists; then
-               ewarn "Cannot determine configuration of your kernel."
-               return
-       fi
-
-       local nf_nat_ftp_ok="yes"
-       local nf_conntrack_ftp_ok="yes"
-       local nf_conntrack_netbios_ns_ok="yes"
-
-       linux_chkconfig_present \
-               NF_NAT_FTP || nf_nat_ftp_ok="no"
-       linux_chkconfig_present \
-               NF_CONNTRACK_FTP || nf_conntrack_ftp_ok="no"
-       linux_chkconfig_present \
-               NF_CONNTRACK_NETBIOS_NS || nf_conntrack_netbios_ns_ok="no"
-
-       # This is better than an essay for each unset option...
-       if [[ ${nf_nat_ftp_ok} = no ]] || [[ ${nf_conntrack_ftp_ok} = no ]] \
-               || [[ ${nf_conntrack_netbios_ns_ok} = no ]]
-       then
-               echo
-               local mod_msg="Kernel options listed below are not set. They are not"
-               mod_msg+=" mandatory, but they are often useful."
-               mod_msg+=" If you don't need some of them, please remove relevant"
-               mod_msg+=" module name(s) from IPT_MODULES in"
-               mod_msg+=" '${EROOT}etc/default/ufw' before (re)starting ufw."
-               mod_msg+=" Otherwise ufw may fail to start!"
-               ewarn "${mod_msg}"
-               if [[ ${nf_nat_ftp_ok} = no ]]; then
-                       ewarn "NF_NAT_FTP: for better support for active mode FTP."
-               fi
-               if [[ ${nf_conntrack_ftp_ok} = no ]]; then
-                       ewarn "NF_CONNTRACK_FTP: for better support for active mode FTP."
-               fi
-               if [[ ${nf_conntrack_netbios_ns_ok} = no ]]; then
-                       ewarn "NF_CONNTRACK_NETBIOS_NS: for better Samba support."
-               fi
-       fi
-}
-
-python_prepare_all() {
-       # Set as enabled by default. User can enable or disable
-       # the service by adding or removing it to/from a runlevel.
-       sed -i 's/^ENABLED=no/ENABLED=yes/' conf/ufw.conf \
-               || die "sed failed (ufw.conf)"
-
-       sed -i "s/^IPV6=yes/IPV6=$(usex ipv6)/" conf/ufw.defaults || die
-
-       # If LINGUAS is set install selected translations only.
-       if [[ -n ${LINGUAS+set} ]]; then
-               _EMPTY_LOCALE_LIST="yes"
-               pushd locales/po > /dev/null || die
-
-               local lang
-               for lang in *.po; do
-                       if ! has "${lang%.po}" ${LINGUAS}; then
-                               rm "${lang}" || die
-                       else
-                               _EMPTY_LOCALE_LIST="no"
-                       fi
-               done
-
-               popd > /dev/null || die
-       else
-               _EMPTY_LOCALE_LIST="no"
-       fi
-
-       distutils-r1_python_prepare_all
-}
-
-python_install_all() {
-       newconfd "${FILESDIR}"/ufw.confd ufw
-       newinitd "${FILESDIR}"/ufw-2.initd ufw
-       systemd_dounit "${FILESDIR}/ufw.service"
-
-       exeinto /usr/share/${PN}
-       doexe tests/check-requirements
-
-       # users normally would want it
-       insinto /usr/share/doc/${PF}/logging/syslog-ng
-       doins "${FILESDIR}"/syslog-ng/*
-
-       insinto /usr/share/doc/${PF}/logging/rsyslog
-       doins "${FILESDIR}"/rsyslog/*
-       doins doc/rsyslog.example
-
-       if use examples; then
-               insinto /usr/share/doc/${PF}/examples
-               doins examples/*
-       fi
-       newbashcomp shell-completion/bash ${PN}
-
-       [[ $_EMPTY_LOCALE_LIST != yes ]] && domo locales/mo/*.mo
-
-       distutils-r1_python_install_all
-       python_replicate_script "${D}usr/sbin/ufw"
-}
-
-pkg_postinst() {
-       if [[ -z ${REPLACING_VERSIONS} ]]; then
-               echo
-               elog "To enable ufw, add it to boot sequence and activate it:"
-               elog "-- # rc-update add ufw boot"
-               elog "-- # /etc/init.d/ufw start"
-               echo
-               elog "If you want to keep ufw logs in a separate file, take a look at"
-               elog "/usr/share/doc/${PF}/logging."
-       fi
-       if [[ -z ${REPLACING_VERSIONS} ]] \
-               || [[ ${REPLACING_VERSIONS} < 0.34 ]];
-       then
-               echo
-               elog "/usr/share/ufw/check-requirements script is installed."
-               elog "It is useful for debugging problems with ufw. However one"
-               elog "should keep in mind that the script assumes IPv6 is enabled"
-               elog "on kernel and net-firewall/iptables, and fails when it's not."
-       fi
-       echo
-       ewarn "Note: once enabled, ufw blocks also incoming SSH connections by"
-       ewarn "default. See README, Remote Management section for more information."
-}