app-admin/consul: Version bump to 1.2.2
authorManuel Rüger <mrueg@gentoo.org>
Tue, 31 Jul 2018 18:09:11 +0000 (20:09 +0200)
committerManuel Rüger <mrueg@gentoo.org>
Tue, 31 Jul 2018 18:09:11 +0000 (20:09 +0200)
Package-Manager: Portage-2.3.43, Repoman-2.3.10

app-admin/consul/Manifest
app-admin/consul/consul-1.2.2.ebuild [new file with mode: 0644]

index 0c5790da38df0dd411ab5a63fb31df7d340038a6..b3529731d152777babcbd49cadcd7defe6975c37 100644 (file)
@@ -1,3 +1,4 @@
 DIST consul-1.0.6.tar.gz 8211299 BLAKE2B 7ea5df497f4796e572a86127e0854935f97439504aff82fb697f33700e9d138048772f32f171dbbe4f1fb4d1ceefa7ca96cf3dce2a22cdffd4e1906f6befa55b SHA512 c55f09272859b828816ddf548952769172331c22be8a70a7f73ab9362744fb1f4bc5fdf81955a0dbc4101584cf3660f182620dcdc56bcf94b42dce644be232a8
 DIST consul-1.2.0.tar.gz 17187054 BLAKE2B 5e8d1151efe1e8ad5932886367d0012774713081aa2725f10d45af1e05751e328d76471ff3cbd85031c252c65cde0137f96c3ef86eca7e3e7f6b28e2d20ed0d5 SHA512 1c018a5f35164a899a086ccdae94cb5e6e2a490e4c788d65b0026dbf448950d0c1038b2d61cb10f5e8c9ad22a1affad64dd4a7086b59dffd115d40aa7b3d0cce
 DIST consul-1.2.1.tar.gz 14819500 BLAKE2B debb7ee5b8016527de0ebc680b228a9749435db4364e8d6e0160b1a20e2896dd4109edc5930dad961ce18f79182dda0c00a52a567ea6ff2d267b17448df2129d SHA512 5b5d8b62056c305f7388db50b54427ed21c41fef6d1b5f67da845a66bece35454e9f538bb0df59bc86788826b6cd20cd6179552060482908fc5cbc4a048c14a8
+DIST consul-1.2.2.tar.gz 15789375 BLAKE2B 8a0af370568f6fcb90334b147bd84e479efb682ed6c58d63dd56f3554f9e6538d37963ac825bb8598eef8948492feec688b8266733223d1557dbce9704daef35 SHA512 715f69e7b36d0070ea4e602dc50f51aa2547dbbbbb07cce985da79d1e201c6e84dade8a7c810e3602f88cfbd30e063669076954d2541810a18a0c9e7c9ff8458
diff --git a/app-admin/consul/consul-1.2.2.ebuild b/app-admin/consul/consul-1.2.2.ebuild
new file mode 100644 (file)
index 0000000..e754310
--- /dev/null
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-vcs-snapshot systemd user
+GIT_COMMIT="e716d1b"
+KEYWORDS="~amd64"
+EGO_PN="github.com/hashicorp/consul"
+DESCRIPTION="A tool for service discovery, monitoring and configuration"
+HOMEPAGE="https://www.consul.io"
+SRC_URI="https://github.com/hashicorp/consul/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MPL-2.0"
+IUSE=""
+
+RESTRICT="test"
+
+DEPEND="dev-go/gox
+       >=dev-lang/go-1.9:=
+       >=dev-go/go-tools-0_pre20160121"
+RDEPEND=""
+
+pkg_setup() {
+       enewgroup consul
+       enewuser consul -1 -1 /var/lib/${PN} consul
+}
+
+src_prepare() {
+       default
+
+       sed -e 's:go get -u -v $(GOTOOLS)::' \
+               -e 's:vendorfmt dev-build:dev-build:' \
+               -i "src/${EGO_PN}/GNUmakefile" || die
+}
+
+src_compile() {
+       # The dev target sets causes build.sh to set appropriate XC_OS
+       # and XC_ARCH, and skips generation of an unused zip file,
+       # avoiding a dependency on app-arch/zip.
+       GOPATH="${S}" \
+       GOBIN="${S}/bin" \
+       GIT_DESCRIBE="v${PV}" \
+       GIT_DIRTY="" \
+       GIT_COMMIT="${GIT_COMMIT}" \
+       emake -C "src/${EGO_PN}" dev-build
+}
+
+src_install() {
+       local x
+
+       dobin bin/consul
+
+       keepdir /etc/consul.d
+       insinto /etc/consul.d
+       doins "${FILESDIR}/"*.json.example
+
+       for x in /var/{lib,log}/${PN}; do
+               keepdir "${x}"
+               fowners consul:consul "${x}"
+       done
+
+       newinitd "${FILESDIR}/consul.initd" "${PN}"
+       newconfd "${FILESDIR}/consul.confd" "${PN}"
+       insinto /etc/logrotate.d
+       newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+       systemd_dounit "${FILESDIR}/consul.service"
+}