net-misc/smbc: EAPI=7 bump
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>
Sun, 19 May 2019 15:38:42 +0000 (17:38 +0200)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Tue, 4 Jun 2019 04:44:38 +0000 (06:44 +0200)
Closes: https://bugs.gentoo.org/686328
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com>
net-misc/smbc/smbc-1.2.2-r3.ebuild [new file with mode: 0644]

diff --git a/net-misc/smbc/smbc-1.2.2-r3.ebuild b/net-misc/smbc/smbc-1.2.2-r3.ebuild
new file mode 100644 (file)
index 0000000..87ebd6e
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Text mode (ncurses) SMB network commander. Features: resume and UTF-8"
+HOMEPAGE="https://sourceforge.net/projects/smbc/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="nls debug"
+
+DEPEND="dev-libs/popt
+       net-fs/samba
+       sys-libs/ncurses
+       nls? ( sys-devel/gettext )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       default
+       mv configure.{in,ac} || die
+       eapply "${FILESDIR}"/${P}-cflags.patch
+       eapply "${FILESDIR}"/${P}-size_t.patch
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               $(use_enable nls) \
+               $(use_with debug)
+}
+
+src_install() {
+       default
+       mkdir -p "${D}/usr/share/doc"
+       mv -v "${D}/usr/share/"{${PN},doc/${PF}} || die
+}