net-libs/libssh2: Version 1.8.1
authorJeroen Roovers <jer@gentoo.org>
Mon, 18 Mar 2019 22:07:02 +0000 (23:07 +0100)
committerJeroen Roovers <jer@gentoo.org>
Mon, 18 Mar 2019 22:07:45 +0000 (23:07 +0100)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Bug: https://bugs.gentoo.org/680904
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-libs/libssh2/Manifest
net-libs/libssh2/libssh2-1.8.1.ebuild [new file with mode: 0644]

index b0d04fff42baa31df812e2b81805a939c415222f..d4134bebb474052b0fdfbb2e126f72d0d1d787d0 100644 (file)
@@ -1 +1,2 @@
 DIST libssh2-1.8.0.tar.gz 854916 BLAKE2B 618c4a19789f2e5eda85852760dffff5672d420d2fa50393b05b7398a1913f74e5f6695f078628050ac9851965d6e45cf410b7c4590a8f18d67c718c829ab352 SHA512 289aa45c4f99653bebf5f99565fe9c519abc204feb2084b47b7cc3badc8bf4ecdedd49ea6acdce8eb902b3c00995d5f92a3ca77b2508b92f04ae0e7de7287558
+DIST libssh2-1.8.1.tar.gz 858088 BLAKE2B 4e7358c55355265ec3c7d7ce749b01d74bc1c37ba73467401c24f0abb2b22da12ba938393f3cf7278ef30900c0cfa700ab71c4fd32a1d41eaeb6fb47669c1ee1 SHA512 f09ad9ed04d25305b966e7f8c210082fe06c2b236dcd5018b009bd0bd6aaff123d16559d280892a5060760ed055ffe295bc02dc6e8dd1e7b8383c6c703f09290
diff --git a/net-libs/libssh2/libssh2-1.8.1.ebuild b/net-libs/libssh2/libssh2-1.8.1.ebuild
new file mode 100644 (file)
index 0000000..75e39f5
--- /dev/null
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-multilib
+
+DESCRIPTION="Library implementing the SSH2 protocol"
+HOMEPAGE="https://www.libssh2.org"
+SRC_URI="https://www.${PN}.org/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="gcrypt libressl mbedtls zlib"
+REQUIRED_USE="
+       ?? ( gcrypt libressl mbedtls )
+"
+RESTRICT="test"
+
+RDEPEND="
+       !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
+       gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
+       libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
+       mbedtls? ( net-libs/mbedtls[${MULTILIB_USEDEP}] )
+       zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
+"
+DEPEND="
+       ${RDEPEND}
+"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.8.0-libgcrypt-prefix.patch
+       "${FILESDIR}"/${PN}-1.8.0-mansyntax_sh.patch
+       "${FILESDIR}"/${PN}-1.8.0-openssl11-memleak.patch
+       "${FILESDIR}"/${PN}-1.8.0-openssl11.patch
+)
+
+multilib_src_configure() {
+       local crypto_backend=OpenSSL
+       if use gcrypt; then
+               crypto_backend=Libgcrypt
+       elif use mbedtls; then
+               crypto_backend=mbedTLS
+       fi
+
+       local mycmakeargs=(
+               -DBUILD_SHARED_LIBS=ON
+               -DCRYPTO_BACKEND=${crypto_backend}
+               -DENABLE_ZLIB_COMPRESSION=$(usex zlib)
+       )
+       cmake-utils_src_configure
+}
+
+multilib_src_install_all() {
+       einstalldocs
+       find "${ED}" -name '*.la' -delete || die
+       mv "${ED}"/usr/share/doc/${PN}/* "${ED}"/usr/share/doc/${PF}/ || die
+       rm -r "${ED}"/usr/share/doc/${PN}/ || die
+}