dev-python/process-tests: Version bump to 2.0.2
authorPatrick McLean <patrick.mclean@sony.com>
Wed, 20 Nov 2019 22:11:59 +0000 (14:11 -0800)
committerPatrick McLean <chutzpah@gentoo.org>
Thu, 21 Nov 2019 02:02:20 +0000 (18:02 -0800)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/process-tests/Manifest
dev-python/process-tests/process-tests-2.0.2.ebuild [new file with mode: 0644]

index 9c3b2ecadc21ded2013af45bcd600ddee06c8e22..0f7c065737f399f8229d36a295c8c427a6df1493 100644 (file)
@@ -1 +1,2 @@
 DIST process-tests-1.2.0.tar.gz 5478 BLAKE2B e210945253e0a5437b68b47f3621b82642379f8ead297cb63b76fb010f8276a5e3d007435c4f837c7ff0ce83ba38cf57dd8963eaa480219e34fcbce9f8cc22b6 SHA512 b5cbe96dbeb6421b26f5a50cfe91bcac2f5d527830dad678df5e0ed1b2019483eab6102ba548483dd6695c881f29380ead2a8b6851c40119815363549ecf5bb6
+DIST process-tests-2.0.2.tar.gz 4815 BLAKE2B 14f2b2e266fd7365c4c1382a608ce641734c34c5215131b45b895a6d1d72591c2396332d1483f006ea7333a30993fae98d25e1a95cd58b38995d949c395da035 SHA512 6cf64d14587ab577a0680760ab6be146a60590091a0bbd6fb35d5c06ddf5289fa4d873c5658f882313837291b70adb37a3e41c13f1fe541777e05f5e9dac1750
diff --git a/dev-python/process-tests/process-tests-2.0.2.ebuild b/dev-python/process-tests/process-tests-2.0.2.ebuild
new file mode 100644 (file)
index 0000000..e1fd709
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tools for testing processes"
+HOMEPAGE="https://github.com/ionelmc/python-process-tests https://pypi.org/project/process-tests/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# There are no tests at all, under TODO
+# see https://pypi.org/project/process-tests/2.0.2/
+RESTRICT="test"
+
+DOCS=( README.rst )