dev-java/stax2-api: Removes java-virtual/stax-api dependency and fixes bug 561504.
authorPatrice Clement <monsieurp@gentoo.org>
Tue, 29 Sep 2015 08:09:57 +0000 (08:09 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Tue, 29 Sep 2015 08:09:57 +0000 (08:09 +0000)
Package-Manager: portage-2.2.18
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
dev-java/stax2-api/stax2-api-4.0.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-java/stax2-api/stax2-api-4.0.0-r1.ebuild b/dev-java/stax2-api/stax2-api-4.0.0-r1.ebuild
new file mode 100644 (file)
index 0000000..c0d2d61
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Extended Stax (STandard Api for Xml procesing) API"
+HOMEPAGE="https://github.com/FasterXML/stax2-api"
+SRC_URI="https://github.com/FasterXML/${PN}/archive/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND=">=virtual/jdk-1.6"
+
+S="${WORKDIR}/${PN}-${P}/src"
+JAVA_SRC_DIR="main/java"
+
+src_install() {
+       java-pkg-simple_src_install
+       dodoc ../README.md ../release-notes/VERSION
+}