sys-boot/raspberrypi-firmware: add new 1.20190709
authorAndrey Utkin <andrey_utkin@gentoo.org>
Mon, 15 Jul 2019 19:56:11 +0000 (20:56 +0100)
committerAndrey Utkin <andrey_utkin@gentoo.org>
Mon, 15 Jul 2019 20:30:41 +0000 (21:30 +0100)
Brings Raspberry Pi 4 support to users of this package.

Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
sys-boot/raspberrypi-firmware/Manifest
sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20190709.ebuild [new file with mode: 0644]

index c5c7c3b3dcaa2b2f0fffbde6639f4c638637382b..da122b1ec6482e25e3ef6af3b310babf75f320bb 100644 (file)
@@ -1 +1,2 @@
 DIST raspberrypi-firmware-1.20190215.tar.gz 123074917 BLAKE2B cefedb5c979db7dfd47938aad37a567d91d3ad78247c7a63f789362768ab7a39a1967ac116b4b0475e3b210ab11f6474706df042af85a622e8e7905c85ec7498 SHA512 082f26caf427222d838881e5f1e9fa0136765b3eaf74a84877fc33616fd07e49085db0889226c40c655039a9d41a10566510c7d752cfc48a67b4683616a51193
+DIST raspberrypi-firmware-1.20190709.tar.gz 158835870 BLAKE2B 4e63b3308adcd75f69f66966f1c927449aa8dc65211e6ca5a27dd2a0ed6ed32cc85ad42221308f4fb3a852d9f278400cfe4f723f306abe102341568408027174 SHA512 6a0610c97db47441ede8e4f8436958899f678bf065a0fbde06de7945a1ac4d5f754a0e10d928d77759ba1cbf82654d85d9cb9c91b970c3fe9590560267033522
diff --git a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20190709.ebuild b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20190709.ebuild
new file mode 100644 (file)
index 0000000..4b06dfa
--- /dev/null
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit mount-boot readme.gentoo-r1
+
+DESCRIPTION="Raspberry Pi (all versions) bootloader and GPU firmware"
+HOMEPAGE="https://github.com/raspberrypi/firmware"
+LICENSE="GPL-2 raspberrypi-videocore-bin"
+SLOT="0"
+
+if [[ "${PV}" == 9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/raspberrypi/firmware"
+       EGIT_CLONE_TYPE="shallow"
+else
+       SRC_URI="https://github.com/raspberrypi/firmware/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="-* ~arm"
+       S="${WORKDIR}/firmware-${PV}"
+fi
+
+RESTRICT="binchecks strip"
+
+pkg_preinst() {
+       if [ -z "${REPLACING_VERSIONS}" ] ; then
+               local msg=""
+               if [ -e "${D}"/boot/cmdline.txt -a -e /boot/cmdline.txt ] ; then
+                       msg+="/boot/cmdline.txt "
+               fi
+               if [ -e "${D}"/boot/config.txt -a -e /boot/config.txt ] ; then
+                       msg+="/boot/config.txt "
+               fi
+               if [ -n "${msg}" ] ; then
+                       msg="This package installs following files: ${msg}."
+                       msg="${msg} Please remove(backup) your copies durning install"
+                       msg="${msg} and merge settings afterwards."
+                       msg="${msg} Further updates will be CONFIG_PROTECTed."
+                       die "${msg}"
+               fi
+       fi
+}
+
+src_install() {
+       insinto /boot
+       cd boot || die
+       doins bootcode.bin fixup*.dat start*elf
+       doins *.dtb
+       doins -r overlays
+       newins "${FILESDIR}"/${PN}-0_p20130711-config.txt config.txt
+       newins "${FILESDIR}"/${PN}-0_p20130711-cmdline.txt cmdline.txt
+       newenvd "${FILESDIR}"/${PN}-0_p20130711-envd 90${PN}
+       readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+       readme.gentoo_print_elog
+}
+
+DOC_CONTENTS="Please configure your ram setup by editing /boot/config.txt"