Version bump; remove old version.
authorHans de Graaff <graaff@gentoo.org>
Fri, 2 Feb 2007 13:08:09 +0000 (13:08 +0000)
committerHans de Graaff <graaff@gentoo.org>
Fri, 2 Feb 2007 13:08:09 +0000 (13:08 +0000)
Package-Manager: portage-2.1.1-r2

dev-ruby/rmagick/ChangeLog
dev-ruby/rmagick/files/digest-rmagick-1.15.1 [new file with mode: 0644]
dev-ruby/rmagick/rmagick-1.15.1.ebuild [new file with mode: 0644]

index 579047201f9bba0cb7c98ed4612aca0191225387..e4ea2d85d061be2a504031ce38261577fd21e5a1 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-ruby/rmagick
 # Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.38 2007/01/31 01:29:10 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.39 2007/02/02 13:08:09 graaff Exp $
+
+*rmagick-1.15.1 (02 Feb 2007)
+
+  02 Feb 2007; Hans de Graaff <graaff@gentoo.org> -rmagick-1.14.1.ebuild,
+  +rmagick-1.15.1.ebuild:
+  Version bump to fix compatibility with ImageMagick 6.0.*. Remove old version.
 
   31 Jan 2007; Jeroen Roovers <jer@gentoo.org> rmagick-1.14.1-r1.ebuild:
   Stable for HPPA (bug #162682).
diff --git a/dev-ruby/rmagick/files/digest-rmagick-1.15.1 b/dev-ruby/rmagick/files/digest-rmagick-1.15.1
new file mode 100644 (file)
index 0000000..62f71aa
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 71cefd5253c4350fc23c42db67cf432a RMagick-1.15.1.tar.bz2 957420
+RMD160 bc4fc5d4529ccff36356477f808f2bfae72c31e2 RMagick-1.15.1.tar.bz2 957420
+SHA256 4179aca49557625956794dfaca6235e5dc99e2558014fcfbb4a739b7df938127 RMagick-1.15.1.tar.bz2 957420
diff --git a/dev-ruby/rmagick/rmagick-1.15.1.ebuild b/dev-ruby/rmagick/rmagick-1.15.1.ebuild
new file mode 100644 (file)
index 0000000..ae01885
--- /dev/null
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/rmagick-1.15.1.ebuild,v 1.1 2007/02/02 13:08:09 graaff Exp $
+
+inherit ruby
+
+# The gem for this package doesn't seem to play well with portage.  It
+# runs a GNUish configure script, with argument passed directly from
+# the gem install command, but gem install doesn't use the same style
+# of arguments.  Thus, unless you're smart enough to come up with a
+# fix, please leave this as a source package install.
+
+DESCRIPTION="An interface between Ruby and the ImageMagick(TM) image processing library"
+HOMEPAGE="http://rmagick.rubyforge.org/"
+SRC_URI="http://rubyforge.org/frs/download.php/17047/RMagick-${PV}.tar.bz2"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="examples doc"
+DEPEND="virtual/ruby
+       >=media-gfx/imagemagick-6.0"
+
+S=${WORKDIR}/RMagick-${PV}
+
+# Using a custom src_compile instead of the ruby one because the ruby
+# one gets confused by an additional setup.rb that should not be used
+# here.
+src_compile() {
+       myconf="${RUBY_ECONF} ${EXTRA_ECONF}"
+
+       # When documentation is built many examples are also run. Not all
+       # of them may work (e.g. due to missing additional dependencies)
+       # so we allow the examples to fail.
+       if ! use doc ; then
+               myconf="${myconf} --disable-htmldoc --enable-allow-example-errors"
+       fi
+
+       ./configure \
+               --prefix=/usr \
+               --host=${CHOST} \
+               --mandir=/usr/share/man \
+               --infodir=/usr/share/info \
+               --datadir=/usr/share \
+               --sysconfdir=/etc \
+               --localstatedir=/var/lib \
+               --with-ruby=${RUBY} \
+               ${myconf} \
+               "$@" || die "econf failed"
+
+       ruby_emake "$@" || die
+}
+
+# Use a custom src_install instead of the default one in ruby.eclass
+# because the one in ruby.eclass does not include setting the prefix
+# for the installation step.
+src_install() {
+       RUBY_ECONF="${RUBY_ECONF} ${EXTRA_ECONF}"
+
+       ${RUBY} setup.rb config --prefix=${D}/usr "$@" \
+               ${RUBY_ECONF} || die "setup.rb config failed"
+       ${RUBY} setup.rb install --prefix=${D} "$@" \
+               ${RUBY_ECONF} || die "setup.rb install failed"
+}