dev-ros/polled_camera: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Wed, 23 Sep 2015 09:16:01 +0000 (11:16 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 23 Sep 2015 09:44:13 +0000 (11:44 +0200)
Package-Manager: portage-2.2.21

dev-ros/polled_camera/Manifest [new file with mode: 0644]
dev-ros/polled_camera/metadata.xml [new file with mode: 0644]
dev-ros/polled_camera/polled_camera-1.11.7.ebuild [new file with mode: 0644]
dev-ros/polled_camera/polled_camera-9999.ebuild [new file with mode: 0644]

diff --git a/dev-ros/polled_camera/Manifest b/dev-ros/polled_camera/Manifest
new file mode 100644 (file)
index 0000000..a917fac
--- /dev/null
@@ -0,0 +1 @@
+DIST image_common-1.11.7.tar.gz 49437 SHA256 1a739aef8ea597f6e7eaad26c031ad90e797efcb9cae764cd352bb124e9744ca SHA512 7408b641c75b6227130218862674609521d8465680ac15d45fc296de6ad3372ef1dde225a812740e0d5200f5923b52b4e9c2fca4dd4f96104f0bfe901400f456 WHIRLPOOL 1c8aee3e738ced0d4b45695a7dd10b1140a330abd8b121c91e2816bed329fc23a1ae39b8150fc81f81b9b586d3a747a9e4d6541914f1caabf6df06cf7cf57441
diff --git a/dev-ros/polled_camera/metadata.xml b/dev-ros/polled_camera/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/polled_camera/polled_camera-1.11.7.ebuild b/dev-ros/polled_camera/polled_camera-1.11.7.ebuild
new file mode 100644 (file)
index 0000000..825bf06
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/sensor_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="C++ helper classes for implementing a polled camera driver node and requesting images from it"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/roscpp
+       dev-ros/image_transport
+       dev-ros/rosconsole
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/polled_camera/polled_camera-9999.ebuild b/dev-ros/polled_camera/polled_camera-9999.ebuild
new file mode 100644 (file)
index 0000000..825bf06
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/sensor_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="C++ helper classes for implementing a polled camera driver node and requesting images from it"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/roscpp
+       dev-ros/image_transport
+       dev-ros/rosconsole
+"
+DEPEND="${RDEPEND}"