dev-libs/appstream-glib: Version bump to 0.7.17
authorMatt Turner <mattst88@gentoo.org>
Tue, 24 Mar 2020 05:33:28 +0000 (22:33 -0700)
committerMatt Turner <mattst88@gentoo.org>
Wed, 25 Mar 2020 02:20:17 +0000 (19:20 -0700)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-libs/appstream-glib/Manifest
dev-libs/appstream-glib/appstream-glib-0.7.17.ebuild [new file with mode: 0644]

index 5e71c93c89dd550e059e86d1fd047d4dc7aa70d5..94894135010cdd955e646d88a8f251cd5d94925a 100644 (file)
@@ -1,2 +1,3 @@
 DIST appstream-glib-0.7.15.tar.xz 2240040 BLAKE2B e1b58e0ce6523354490e529381302aa603e4ac1886c37e9c261ab612f76490ae4ea8fd22eff9c2bc1981d5ceb77ff8c4f8279e091dc62bd4df39d2c32623c1ea SHA512 bab0c73e54d90fbf22295f616d4a09332f94b90a3fa0cb38f1b654c6d9a459c9557dd81c677f486361dbf4f1dd23651306fe34b1cdd15254694269a8c9e8a927
 DIST appstream-glib-0.7.16.tar.xz 2243684 BLAKE2B 101a964822cc2421608e04a342b89248d16fff006c1843433f5db11703533fb7d0b2cb390d1e2f85274c51d0bd989502fc453700dfb9c32005a7b7c64cb59348 SHA512 a2991dbd26deeb1fb1daef1811c38ff5b55b2fae0bf2d8cc612c2e370613cb6b0468cf287ab3b575f6e6e3203aabcca12dd95474f70a54d6052a34dcb27b951b
+DIST appstream-glib-0.7.17.tar.xz 2245372 BLAKE2B 88173b209b275962ecd4b0a5d3cc344b317dec39a57cb6ebcdbc1c4447017b69c8e68ae19e336b1780477120269deda28b7e53d935a057fac193f123d91013d0 SHA512 72eae6057a4b18b6eca34c795c2bfd982fd7a31500b70beb9553bdf8a7617a03319a2813eb93af20f2e39678ef6ee524dee48b2cbcccde0736f9d10a547ca223
diff --git a/dev-libs/appstream-glib/appstream-glib-0.7.17.ebuild b/dev-libs/appstream-glib/appstream-glib-0.7.17.ebuild
new file mode 100644 (file)
index 0000000..3ac1858
--- /dev/null
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit xdg meson
+
+DESCRIPTION="Provides GObjects and helper methods to read and write AppStream metadata"
+HOMEPAGE="https://people.freedesktop.org/~hughsient/appstream-glib/"
+SRC_URI="https://people.freedesktop.org/~hughsient/${PN}/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/8" # soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="gtk-doc fonts +introspection stemmer"
+
+RDEPEND="
+       >=dev-libs/glib-2.58.0:2
+       sys-apps/util-linux
+       app-arch/libarchive
+       >=net-libs/libsoup-2.51.92:2.4
+       >=dev-libs/json-glib-1.1.2
+       >=x11-libs/gdk-pixbuf-2.31.5:2[introspection?]
+
+       fonts? ( x11-libs/gtk+:3
+               >=media-libs/freetype-2.4:2 )
+       >=media-libs/fontconfig-2.11:1.0
+       dev-libs/libyaml
+       stemmer? ( dev-libs/snowball-stemmer )
+       x11-libs/pango
+       introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+# libxml2 required for glib-compile-resources
+DEPEND="${RDEPEND}
+       dev-util/gperf
+
+       dev-libs/libxml2:2
+       app-text/docbook-xml-dtd:4.2
+       dev-libs/libxslt
+       gtk-doc? (
+               >=dev-util/gtk-doc-1.9
+               app-text/docbook-xml-dtd:4.3
+       )
+       >=sys-devel/gettext-0.19.8
+"
+# ${PN} superseeds appdata-tools
+RDEPEND="${RDEPEND}
+       !<dev-util/appdata-tools-0.1.8-r1
+"
+
+src_configure() {
+       local emesonargs=(
+               -Ddep11=true
+               -Dbuilder=true
+               -Drpm=false
+               -Dalpm=false
+               $(meson_use fonts)
+               $(meson_use stemmer)
+               -Dman=true
+               $(meson_use gtk-doc)
+               $(meson_use introspection)
+       )
+       meson_src_configure
+}