dev-ruby/activestorage: remove vulnerable versions
authorHans de Graaff <graaff@gentoo.org>
Tue, 26 Mar 2019 05:41:56 +0000 (06:41 +0100)
committerHans de Graaff <graaff@gentoo.org>
Tue, 26 Mar 2019 05:44:54 +0000 (06:44 +0100)
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

dev-ruby/activestorage/Manifest
dev-ruby/activestorage/activestorage-5.2.2-r1.ebuild [deleted file]
dev-ruby/activestorage/activestorage-5.2.2.ebuild [deleted file]

index 37061766e2b651f6fcd054deca68c4f07e28fede..d4a6a66cb9f8ac7943c2f887bc149db13ea93d7b 100644 (file)
@@ -1,2 +1 @@
 DIST rails-5.2.2.1.tgz 8795399 BLAKE2B cb07c555b4124b67c12d7b913209112730a2aa4d957b3711c6b1f41918bfbce792426d75bd2e4443043a701f74bb2a286d59b140248f6a74f1c4547f00dc0b7d SHA512 c976e3b4f0f2350cd611309c89a9c3ad16871f115577788694519482afa10420a272f2cc560bd823f05d6d616e3cde1e121d6f530e3d29df12a55bd2aa76ed0e
-DIST rails-5.2.2.tgz 8794009 BLAKE2B ee6af6990d6b3dc12171fa2a1baf0f975481dc31711ae2caed27b79d1c5b514d1959492c5cced5b0202b46fc18e4a8178703a91b5f1f65df4ea46f193e9d48d5 SHA512 ecca752baa52ee7f11ef21a919bbba370d9ca76a0b428305143e86ebabbd7218978cdeefc919bfb1c0e0e71fc555869dcf917bda219f89e7e41e17dfe983b792
diff --git a/dev-ruby/activestorage/activestorage-5.2.2-r1.ebuild b/dev-ruby/activestorage/activestorage-5.2.2-r1.ebuild
deleted file mode 100644 (file)
index 58cfcf6..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="activestorage.gemspec"
-
-RUBY_FAKEGEM_EXTRAINSTALL="app config db"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem eapi7-ver
-
-DESCRIPTION="Attach cloud and local files in Rails applications"
-HOMEPAGE="https://github.com/rails/rails"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1-2)"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-DEPEND+=" test? ( app-text/mupdf ) "
-
-ruby_add_rdepend "
-       ~dev-ruby/actionpack-${PV}:*
-       ~dev-ruby/activerecord-${PV}:*
-       >=dev-ruby/marcel-0.3.1 =dev-ruby/marcel-0.3*
-"
-
-ruby_add_bdepend "
-       test? (
-               ~dev-ruby/railties-${PV}
-               dev-ruby/test-unit:2
-               dev-ruby/mini_magick
-               dev-ruby/mocha
-               dev-ruby/rake
-               dev-ruby/sqlite3
-       )"
-
-all_ruby_prepare() {
-          # Remove items from the common Gemfile that we don't need for this
-               # test run. This also requires handling some gemspecs.
-               sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|aws-sdk-s3\|google-cloud-storage\|azure-storage\|blade\|bootsnap\|hiredis\|qunit-selenium\|chromedriver-helper\|redis\|rb-inotify\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|sass-rails\|rubocop\|capybara\|rack-cache\|json\|dalli\|listen\|connection_pool\|puma\|mysql2\)/ s:^:#:" \
-                       -e '/dalli/ s/2.7.7/2.7.9/' \
-                       -e '/:job/,/end/ s:^:#:' \
-                       -e '/:test/,/^end/ s:^:#:' \
-                       -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
-               rm ../Gemfile.lock || die
-}
diff --git a/dev-ruby/activestorage/activestorage-5.2.2.ebuild b/dev-ruby/activestorage/activestorage-5.2.2.ebuild
deleted file mode 100644 (file)
index fc1d90b..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="activestorage.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem eapi7-ver
-
-DESCRIPTION="Attach cloud and local files in Rails applications"
-HOMEPAGE="https://github.com/rails/rails"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1-2)"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-DEPEND+=" test? ( app-text/mupdf ) "
-
-ruby_add_rdepend "
-       ~dev-ruby/actionpack-${PV}:*
-       ~dev-ruby/activerecord-${PV}:*
-       >=dev-ruby/marcel-0.3.1 =dev-ruby/marcel-0.3*
-"
-
-ruby_add_bdepend "
-       test? (
-               ~dev-ruby/railties-${PV}
-               dev-ruby/test-unit:2
-               dev-ruby/mini_magick
-               dev-ruby/mocha
-               dev-ruby/rake
-               dev-ruby/sqlite3
-       )"
-
-all_ruby_prepare() {
-          # Remove items from the common Gemfile that we don't need for this
-               # test run. This also requires handling some gemspecs.
-               sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|aws-sdk-s3\|google-cloud-storage\|azure-storage\|blade\|bootsnap\|hiredis\|qunit-selenium\|chromedriver-helper\|redis\|rb-inotify\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|sass-rails\|rubocop\|capybara\|rack-cache\|json\|dalli\|listen\|connection_pool\|puma\|mysql2\)/ s:^:#:" \
-                       -e '/dalli/ s/2.7.7/2.7.9/' \
-                       -e '/:job/,/end/ s:^:#:' \
-                       -e '/:test/,/^end/ s:^:#:' \
-                       -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
-               rm ../Gemfile.lock || die
-}