sys-kernel/git-sources: Automated version bump to 5.6_rc3.
authorAgostino Sarubbo <ago@gentoo.org>
Mon, 24 Feb 2020 07:37:46 +0000 (08:37 +0100)
committerAgostino Sarubbo <ago@gentoo.org>
Mon, 24 Feb 2020 07:37:46 +0000 (08:37 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
sys-kernel/git-sources/Manifest
sys-kernel/git-sources/git-sources-5.6_rc3.ebuild [new file with mode: 0644]

index 68ed9720f16a556bfaae5d3cff4ad55e36d2bb81..90e891f9e41a8dc5a7c97815aa98ed456056740d 100644 (file)
@@ -1,3 +1,4 @@
 DIST linux-5.5.tar.xz 110713660 BLAKE2B 36b990d3650c409652206c319c93c0cf68885334050bc286b479c8b844bc47354547e19eebb58caafb026b96d134f39f0c7ce38b4eebe9da7ea6d1610a1e2af2 SHA512 fa74fdabb5e63384a39e54da05b86a9ae9ea16179524b041fbbdffc7177e80b53600ae98d76be127ba216148f9dc55fe07ab20637e22c6d6030cb4aa09eb2f86
 DIST patch-5.6-rc1.patch 39491488 BLAKE2B adc1688d19eb26d6b253255c427bea5b1961f1fd10244f06fd3ccc942f19b8f93ff65fa142ed7d7339c7a18409d00bbaa7be30ca1dbb7e02970cd2311c27e54f SHA512 399b5a639171e48e9a45a3f7cd6612aaf953f54996ad3c52fc1e6c7c83b73649bb73c77d3a3675ca6a7740fd51c73a00d8059d743d753ef0eeb231ba55f4ed7d
 DIST patch-5.6-rc2.patch 40918846 BLAKE2B 72e67ad7b6766989cb826d9c54fc3cc1937f33c4a8225956fc331275b4feb385b79c4ba5d77acd67773d064c5e3a20e3006937a2fcaf761dd3ef0ff358780431 SHA512 1448cae996064fe2769fbbc52f6dc4d5b4a24459b37aae6cbf2163902229cae9a6f54347b1f53ce030c7d88a8e8a59463a76f471ec6034259c091b276285380f
+DIST patch-5.6-rc3.patch 41366122 BLAKE2B 73f606aa9e24d7e0b4030f883007c0ee40810ac5ecc52da90c2e58448f15a909529b50ce5e3e33274fb1514264e1522753b68ce92991449c16ff5fe61f8784a2 SHA512 a49a177ec7d527da1ee97c3e2f9b3fc97055452de1d82d743aa609ef0ef1abc345791e5ed3d28ecf833b5af833c6f9af9b5b9e8d0895ca103483e384f5d924d6
diff --git a/sys-kernel/git-sources/git-sources-5.6_rc3.ebuild b/sys-kernel/git-sources/git-sources-5.6_rc3.ebuild
new file mode 100644 (file)
index 0000000..4b09cc6
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.5"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+       >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+       postinst_sources
+}