Fix data loading, bug #158759
authorTristan Heaven <tristan@gentoo.org>
Mon, 1 Jan 2007 01:56:30 +0000 (01:56 +0000)
committerTristan Heaven <tristan@gentoo.org>
Mon, 1 Jan 2007 01:56:30 +0000 (01:56 +0000)
Package-Manager: portage-2.1.2_rc4-r3

games-puzzle/enigma/ChangeLog
games-puzzle/enigma/enigma-1.00-r1.ebuild [new file with mode: 0644]
games-puzzle/enigma/files/digest-enigma-1.00-r1 [new file with mode: 0644]
games-puzzle/enigma/files/enigma-1.00-build.patch [new file with mode: 0644]

index 39255eff1c0869d0abdfe746199c558d1db040d6..7e2bb83a435188d40ac1e2161f55949c5f69ec3f 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for games-puzzle/enigma
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/ChangeLog,v 1.26 2006/12/21 08:47:58 mr_bones_ Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/ChangeLog,v 1.27 2007/01/01 01:56:30 nyhm Exp $
+
+*enigma-1.00-r1 (01 Jan 2007)
+
+  01 Jan 2007; Tristan Heaven <nyhm@gentoo.org>
+  +files/enigma-1.00-build.patch, -enigma-1.00.ebuild,
+  +enigma-1.00-r1.ebuild:
+  Fix data loading, bug #158759
 
 *enigma-1.00 (21 Dec 2006)
 
diff --git a/games-puzzle/enigma/enigma-1.00-r1.ebuild b/games-puzzle/enigma/enigma-1.00-r1.ebuild
new file mode 100644 (file)
index 0000000..36e76b7
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/enigma-1.00-r1.ebuild,v 1.1 2007/01/01 01:56:30 nyhm Exp $
+
+inherit eutils games
+
+DESCRIPTION="puzzle game similar to Oxyd"
+HOMEPAGE="http://www.nongnu.org/enigma/"
+SRC_URI="http://download.berlios.de/enigma-game/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND="media-libs/sdl-ttf
+       media-libs/libsdl
+       media-libs/sdl-mixer
+       media-libs/sdl-image
+       dev-libs/xerces-c
+       nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+       nls? ( sys-devel/gettext )"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+       egamesconf \
+               --disable-dependency-tracking \
+               $(use_enable nls) \
+               || die
+       emake || die "emake failed"
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die "emake install failed"
+       dodoc ACKNOWLEDGEMENTS AUTHORS CHANGES README doc/HACKING
+       dohtml -r doc/*
+       doman doc/enigma.6
+       prepgamesdirs
+}
diff --git a/games-puzzle/enigma/files/digest-enigma-1.00-r1 b/games-puzzle/enigma/files/digest-enigma-1.00-r1
new file mode 100644 (file)
index 0000000..7577ede
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 428a9cce666cd45812e785f00a483ef9 enigma-1.00.tar.gz 10466968
+RMD160 a2ddd9600cddaf6b52c02af1c5631c8c4cd69045 enigma-1.00.tar.gz 10466968
+SHA256 c44f36ef28c8bed1f5d5090edbe4cedda6f37472e729eed3406a350365ca32be enigma-1.00.tar.gz 10466968
diff --git a/games-puzzle/enigma/files/enigma-1.00-build.patch b/games-puzzle/enigma/files/enigma-1.00-build.patch
new file mode 100644 (file)
index 0000000..7a68477
--- /dev/null
@@ -0,0 +1,88 @@
+--- configure
++++ configure
+@@ -13321,7 +13321,6 @@
+       echo "$as_me:$LINENO: result: yes" >&5
+ echo "${ECHO_T}yes" >&6
+ else
+-      CXXFLAGS="$CXXFLAGS -g"
+       echo "$as_me:$LINENO: result: no" >&5
+ echo "${ECHO_T}no" >&6
+ fi
+--- etc/Makefile.in
++++ etc/Makefile.in
+@@ -216,15 +216,15 @@
+ # if !MINGW32
+ # Comply with xdg icon theme specification
+-icondir = $(prefix)/share/icons/hicolor/48x48/apps
++icondir = /usr/share/icons/hicolor/48x48/apps
+ icon_DATA = enigma.png
+ # Backwards-compatible global search location for images
+-pixmapdir = $(prefix)/share/pixmaps
++pixmapdir = /usr/share/pixmaps
+ pixmap_DATA = enigma.png
+ # Install .desktop file in xdg standard location
+-desktopdir = $(prefix)/share/applications
++desktopdir = /usr/share/applications
+ desktop_DATA = enigma.desktop
+ # endif !MINGW32
+ EXTRA_DIST = \
+--- lib-src/enet/include/Makefile.in
++++ lib-src/enet/include/Makefile.in
+@@ -126,7 +126,6 @@
+ sharedstatedir = @sharedstatedir@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+-SUBDIRS = enet
+ all: all-recursive
+ .SUFFIXES:
+--- lib-src/enet/Makefile.in
++++ lib-src/enet/Makefile.in
+@@ -551,7 +551,7 @@
+       for dir in "$(DESTDIR)$(libdir)"; do \
+         test -z "$$dir" || $(mkdir_p) "$$dir"; \
+       done
+-install: install-recursive
++install:
+ install-exec: install-exec-recursive
+ install-data: install-data-recursive
+ uninstall: uninstall-recursive
+--- Makefile.in
++++ Makefile.in
+@@ -239,10 +239,9 @@
+ #   tools -> lib-src/lua
+ #   src   -> tools, lib-src
+ #
+-SUBDIRS = m4 lib-src tools intl src data doc po etc
++SUBDIRS = m4 lib-src tools intl src data po etc
+ EXTRA_DIST = enigma CHANGES ACKNOWLEDGEMENTS
+ docdir = @datadir@/doc/enigma
+-doc_DATA = README CHANGES COPYING ACKNOWLEDGEMENTS
+ ACLOCAL_AMFLAGS = -I m4
+ all: all-recursive
+--- po/Makefile.in.in
++++ po/Makefile.in.in
+@@ -24,7 +24,7 @@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ datadir = @datadir@
+-localedir = $(datadir)/locale
++localedir = /usr/share/locale
+ gettextsrcdir = $(datadir)/gettext/po
+ INSTALL = @INSTALL@
+--- src/Makefile.in
++++ src/Makefile.in
+@@ -144,7 +144,7 @@
+ CXXDEPMODE = @CXXDEPMODE@
+ CXXFLAGS = @CXXFLAGS@\
+       -DSYSTEM_DATA_DIR=\"$(datadir)/enigma\" \
+-      -DLOCALEDIR=\"$(localedir)\" \
++      -DLOCALEDIR=\"/usr/share/locale\" \
+       -I$(top_srcdir)/lib-src/zipios++  \
+       -I$(top_builddir)/lib-src/zipios++ \
+       -I$(top_srcdir)/lib-src/lua \