"Fix data install path, thanks Thomas Cort <tcort@gentoo.org> wrt bug #132197.
authorJon Hood <squinky86@gentoo.org>
Tue, 20 Jun 2006 18:27:48 +0000 (18:27 +0000)
committerJon Hood <squinky86@gentoo.org>
Tue, 20 Jun 2006 18:27:48 +0000 (18:27 +0000)
Package-Manager: portage-2.1_rc4-r5

net-p2p/gift-ares/ChangeLog
net-p2p/gift-ares/files/digest-gift-ares-0.3.0-r1 [new file with mode: 0644]
net-p2p/gift-ares/gift-ares-0.3.0-r1.ebuild [new file with mode: 0644]

index f0bcd7ecb13b4533d43088184d6d883d08019ff4..ff800632f6ec981becf54badfd8863009e3f322b 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for net-p2p/gift-ares
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift-ares/ChangeLog,v 1.4 2006/05/05 14:28:12 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift-ares/ChangeLog,v 1.5 2006/06/20 18:27:48 squinky86 Exp $
+
+*gift-ares-0.3.0-r1 (20 Jun 2006)
+
+  20 Jun 2006; Jon Hood <squinky86@gentoo.org>
+  -files/gift-ares-0.2.2-gentoo.patch, -gift-ares-0.2.1.ebuild,
+  -gift-ares-0.2.2.ebuild, +gift-ares-0.3.0-r1.ebuild:
+  Fix data install path, thanks Thomas Cort <tcort@gentoo.org> wrt bug
+  #132197. Remove old versions.
 
   05 May 2006; Jon Hood <squinky86@gentoo.org> gift-ares-0.3.0.ebuild:
   Install into /usr/lib64 for amd64 systems.
diff --git a/net-p2p/gift-ares/files/digest-gift-ares-0.3.0-r1 b/net-p2p/gift-ares/files/digest-gift-ares-0.3.0-r1
new file mode 100644 (file)
index 0000000..80419e9
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 51ca0cf8aad7e1ea5ffbbca2fa71c1db gift-ares-0.3.0.tar.bz2 311141
+RMD160 31c291a85cb52527c39681fdd4e1fd164255ab85 gift-ares-0.3.0.tar.bz2 311141
+SHA256 bfbd6673c58b8d7304cbfffd0dbb776b4fd6ca0ac5c807d71cdd702d3f411419 gift-ares-0.3.0.tar.bz2 311141
diff --git a/net-p2p/gift-ares/gift-ares-0.3.0-r1.ebuild b/net-p2p/gift-ares/gift-ares-0.3.0-r1.ebuild
new file mode 100644 (file)
index 0000000..6295b4b
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift-ares/gift-ares-0.3.0-r1.ebuild,v 1.1 2006/06/20 18:27:48 squinky86 Exp $
+
+inherit eutils
+
+IUSE=""
+
+DESCRIPTION="Ares Plugin for giFT"
+HOMEPAGE="http://gift-ares.berlios.de/"
+SRC_URI="http://download.berlios.de/${PN}/${P}.tar.bz2"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="dev-util/pkgconfig"
+
+RDEPEND=">=net-p2p/gift-0.11.8"
+
+src_unpack() {
+       unpack ${A}
+       cd ${S}
+}
+
+src_compile() {
+       econf --datadir=/usr/share/giFT || die "Ares plugin failed to configure"
+       emake || die "Ares plugin failed to build"
+}
+
+src_install() {
+       make DESTDIR=${D} plugindir=/usr/$(get_libdir)/giFT install || die "Ares plugin failed to install"
+       dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+       einfo "It is recommended that you re-run gift-setup as"
+       einfo "the user you will run the giFT daemon as:"
+       einfo "\tgift-setup"
+       echo
+       einfo "Alternatively, if this plugin is already"
+       einfo "configured,  you can add the following line"
+       einfo "to ~/.giFT/giftd.conf"
+       einfo "plugins = Ares"
+}