net-fs/samba: Don't build winexe if a mingw compiler has been found
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 6 May 2020 12:09:48 +0000 (14:09 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 6 May 2020 12:15:05 +0000 (14:15 +0200)
Thanks-to: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-fs/samba/files/samba-4.13-winexe_option.patch [new file with mode: 0644]
net-fs/samba/samba-4.11.9.ebuild
net-fs/samba/samba-4.12.2.ebuild

diff --git a/net-fs/samba/files/samba-4.13-winexe_option.patch b/net-fs/samba/files/samba-4.13-winexe_option.patch
new file mode 100644 (file)
index 0000000..63f8a9e
--- /dev/null
@@ -0,0 +1,67 @@
+From 54c21a99e6ca54bdb963c70d322f6778b57a384f Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?G=C3=BCnther=20Deschner?= <gd@samba.org>
+Date: Wed, 4 Mar 2020 18:51:01 +0100
+Subject: [PATCH] winexe: add configure option to control whether to build it
+ (default: auto)
+
+Guenther
+
+Signed-off-by: Guenther Deschner <gd@samba.org>
+Reviewed-by: Andreas Schneider <asn@samba.org>
+
+Autobuild-User(master): Andreas Schneider <asn@cryptomilk.org>
+Autobuild-Date(master): Mon Mar  9 16:27:21 UTC 2020 on sn-devel-184
+---
+ examples/winexe/wscript_build |  3 ++-
+ source3/wscript               | 17 +++++++++++++++++
+ 2 files changed, 19 insertions(+), 1 deletion(-)
+
+diff --git a/examples/winexe/wscript_build b/examples/winexe/wscript_build
+index 43c09717e3d..559ed3fc706 100644
+--- a/examples/winexe/wscript_build
++++ b/examples/winexe/wscript_build
+@@ -106,4 +106,5 @@ if winexesvc_binaries != '':
+                           LOADPARM_CTX
+                           libsmb
+                           msrpc3
+-                      ''')
++                      ''',
++                      enabled=bld.env.build_winexe)
+diff --git a/source3/wscript b/source3/wscript
+index 85466b493fa..6d5bd22ca49 100644
+--- a/source3/wscript
++++ b/source3/wscript
+@@ -63,6 +63,7 @@ def options(opt):
+     opt.samba_add_onoff_option('cluster-support', default=False)
+     opt.samba_add_onoff_option('regedit', default=None)
++    opt.samba_add_onoff_option('winexe', default=None)
+     opt.samba_add_onoff_option('fake-kaserver',
+                           help=("Include AFS fake-kaserver support"), default=False)
+@@ -1782,6 +1783,22 @@ main() {
+     if conf.CHECK_HEADERS('ftw.h') and conf.CHECK_FUNCS('nftw'):
+         conf.env.build_mvxattr = True
++    conf.env.build_winexe = False
++    if not Options.options.with_winexe == False:
++        if conf.CONFIG_SET('HAVE_WINEXE_CC_WIN32') or conf.CONFIG_SET('HAVE_WINEXE_CC_WIN64'):
++            conf.env.build_winexe = True
++
++    if conf.env.build_winexe:
++        Logs.info("building winexe")
++    else:
++        if Options.options.with_winexe == False:
++            Logs.info("not building winexe (--without-winexe)")
++        elif Options.options.with_winexe == True:
++            Logs.error("mingw not available, cannot build winexe")
++            conf.fatal("mingw not available, but --with-winexe was specified")
++        else:
++            Logs.info("mingw not available, not building winexe")
++
+     conf.CHECK_FUNCS_IN('DES_pcbc_encrypt', 'crypto')
+     if Options.options.with_fake_kaserver == True:
+         conf.CHECK_HEADERS('afs/param.h afs/stds.h', together=True)
+-- 
+2.26.2
+
index 3b29750587350775b93701c837a6c20fdac0b572..3fe07a3d4303e3665fc2d6c6dfc7889abcbcfb6f 100644 (file)
@@ -132,6 +132,7 @@ S="${WORKDIR}/${MY_P}"
 PATCHES=(
        "${FILESDIR}/${PN}-4.4.0-pam.patch"
        "${FILESDIR}/${PN}-4.9.2-timespec.patch"
+       "${FILESDIR}/${PN}-4.13-winexe_option.patch"
 )
 
 #CONFDIR="${FILESDIR}/$(get_version_component_range 1-2)"
@@ -192,6 +193,7 @@ multilib_src_configure() {
                --disable-rpath-install
                --nopyc
                --nopyo
+               --without-winexe
                $(multilib_native_use_with acl acl-support)
                $(multilib_native_usex addc '' '--without-ad-dc')
                $(multilib_native_use_with addns dnsupdate)
index c74d0e143b985dc23d8895be70cb127f445f6695..445bae6f796d161e50b57e2f2094f9fe7159a583 100644 (file)
@@ -134,6 +134,7 @@ S="${WORKDIR}/${MY_P}"
 PATCHES=(
        "${FILESDIR}/${PN}-4.4.0-pam.patch"
        "${FILESDIR}/${PN}-4.9.2-timespec.patch"
+       "${FILESDIR}/${PN}-4.13-winexe_option.patch"
 )
 
 #CONFDIR="${FILESDIR}/$(get_version_component_range 1-2)"
@@ -194,6 +195,7 @@ multilib_src_configure() {
                --disable-rpath-install
                --nopyc
                --nopyo
+               --without-winexe
                $(multilib_native_use_with acl acl-support)
                $(multilib_native_usex addc '' '--without-ad-dc')
                $(multilib_native_use_with addns dnsupdate)