media-tv/mythtv: Fix fail when USE = -python
authorWilson Michaels <thebitpit@earthlink.net>
Mon, 2 Mar 2020 18:57:57 +0000 (12:57 -0600)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 3 Mar 2020 14:53:42 +0000 (16:53 +0200)
Closes: https://bugs.gentoo.org/711172
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Wilson Michaels <thebitpit@earthlink.net>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
media-tv/mythtv/mythtv-29.1-r2.ebuild
media-tv/mythtv/mythtv-30.0_p20190808-r2.ebuild

index c386ea2be4ff324990b674343129db5deea42f4e..4f6a3c212b50527049709c65b7a695f7123dba8f 100644 (file)
@@ -285,6 +285,7 @@ src_configure() {
 src_install() {
        emake STRIP="true" INSTALL_ROOT="${D}" install
        dodoc AUTHORS UPGRADING README
+       use python && python_optimize  # does all packages by default
        readme.gentoo_create_doc
 
        insinto /usr/share/mythtv/database
@@ -336,7 +337,7 @@ src_install() {
        done
 
        # Ensure that Python scripts are executed by Python 2
-       python_fix_shebang "${ED}/usr/share/mythtv"
+       use python && python_fix_shebang "${ED}/usr/share/mythtv"
 
        # Make shell & perl scripts executable
        find "${ED}" -type f -name '*.sh' -o -type f -name '*.pl' | \
index b09dc0235f971601d202ee5e3a99b15b7ff91359..67f54fca3c2b7e39145c2fab757131a8b3c11b9d 100644 (file)
@@ -357,7 +357,7 @@ src_configure() {
 
 src_install() {
        emake STRIP="true" INSTALL_ROOT="${D}" install
-       python_optimize  # does all packages by default
+       use python && python_optimize  # does all packages by default
        dodoc AUTHORS UPGRADING README
        readme.gentoo_create_doc
 
@@ -408,7 +408,7 @@ src_install() {
                -exec chmod a+x {} \; || die "Failed to make python file $(basename ${file}) executable"
 
        # Ensure that Python scripts are executed by Python 2
-       python_fix_shebang "${ED}/usr/share/mythtv"
+       use python && python_fix_shebang "${ED}/usr/share/mythtv"
 
        # Make shell & perl scripts executable
        find "${ED}" -type f \( -name '*.sh' -o -name '*.pl' \) -exec chmod a+x {} \; || die "Failed to make script executable"