net-dns/libidn2: Version bump.
authorJeroen Roovers <jer@gentoo.org>
Mon, 8 May 2017 14:26:54 +0000 (16:26 +0200)
committerJeroen Roovers <jer@gentoo.org>
Mon, 8 May 2017 14:26:54 +0000 (16:26 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.2

net-dns/libidn2/Manifest
net-dns/libidn2/libidn2-2.0.2.ebuild [new file with mode: 0644]

index ea57bda7c61dc5a01eda6bb7abfd41a539021abc..946d24e796ed3ea657984ad5a5340cbf1df0470b 100644 (file)
@@ -1,2 +1,3 @@
 DIST libidn2-0.16.tar.gz 1494295 SHA256 2fad9efff4082ae2143f69df76339ca99379e0e0f4231455f5d3d9d2089c688f SHA512 85f41c79bd2b88f2724383461a78e56b47e52e66e3f088d631a922438742938721d26aeebef17f6ca4fd028d95dfb5b0fa298a96982ef777c07fefe5244d1e73 WHIRLPOOL be10d0e2994e4fa0e31d710b358c7375e9454b4291bd4603a683a6ddb737241442007f04893395b36d7ef636614b6982354840bb07570e2a6b8f6aa2d888996a
 DIST libidn2-2.0.0.tar.xz 1257908 SHA256 039052f2a3c513c56b9961b8afb7379e68a0698032e228953e89b169b88d7838 SHA512 0cc199f05526edebb385cd7ca3bafca341e31cc76ef0efe7e63a07ff1d2830d9d33004dfc51aa245b42fdf0de7eeb807fd18255f58cc2b086e1155beaa738502 WHIRLPOOL daa222e6a3527cbc989a0388cb903e428acd759553e668b97f2ca2b9071067e43a6c23a8b3e52e7bbd98c71788b2ee009ce5f640a09051b5fcca04a50b543d2d
+DIST libidn2-2.0.2.tar.gz 1925342 SHA256 8cd62828b2ab0171e0f35a302f3ad60c3a3fffb45733318b3a8205f9d187eeab SHA512 c8fd1114fc8df2030abf7c1044da4022989a1cd7ecd92309f62ad0b51b1fcf40418dccd2e397a8335c5e99998130f25339dcb576b4bc88888e3ef0df89714dad WHIRLPOOL fc60b6b8da20b60c851001788541ede0b7ce64ea9701a229b7312b748b02cf99f70d14070ffd64967f6b970f1ce43589956bad693d13f8b51ddde27515fd47c1
diff --git a/net-dns/libidn2/libidn2-2.0.2.ebuild b/net-dns/libidn2/libidn2-2.0.2.ebuild
new file mode 100644 (file)
index 0000000..5ffb826
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils flag-o-matic multilib-minimal
+
+DESCRIPTION="An implementation of the IDNA2008 specifications (RFCs 5890, 5891, 5892, 5893)"
+HOMEPAGE="https://www.gnu.org/software/libidn/#libidn2 https://gitlab.com/jas/libidn2"
+SRC_URI="
+       mirror://gnu/libidn/${P}.tar.gz
+"
+
+LICENSE="GPL-2+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND="
+       dev-libs/libunistring[${MULTILIB_USEDEP}]
+"
+DEPEND="
+       ${RDEPEND}
+       dev-lang/perl
+       sys-apps/help2man
+"
+
+src_prepare() {
+       default
+
+       if [[ ${CHOST} == *-darwin* ]] ; then
+               # Darwin ar chokes when TMPDIR doesn't exist (as done for some
+               # reason in the Makefile)
+               sed -i -e '/^TMPDIR = /d' Makefile.in || die
+               export TMPDIR="${T}"
+       fi
+
+       multilib_copy_sources
+}
+
+multilib_src_configure() {
+       econf \
+               $(use_enable static-libs static) \
+               --disable-gtk-doc
+}
+
+multilib_src_install() {
+       default
+
+       prune_libtool_files
+}