dev-libs/dmalloc: Remove old
authorDavid Seifert <soap@gentoo.org>
Tue, 18 Feb 2020 19:11:07 +0000 (20:11 +0100)
committerDavid Seifert <soap@gentoo.org>
Tue, 18 Feb 2020 19:11:07 +0000 (20:11 +0100)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-libs/dmalloc/dmalloc-5.5.2-r4.ebuild [deleted file]
dev-libs/dmalloc/dmalloc-5.5.2-r6.ebuild [deleted file]

diff --git a/dev-libs/dmalloc/dmalloc-5.5.2-r4.ebuild b/dev-libs/dmalloc/dmalloc-5.5.2-r4.ebuild
deleted file mode 100644 (file)
index 0e973b2..0000000
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit autotools eutils multilib
-
-DESCRIPTION="A Debug Malloc Library"
-HOMEPAGE="http://dmalloc.com"
-SRC_URI="http://dmalloc.com/releases/${P}.tgz"
-
-LICENSE="CC-BY-SA-3.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86"
-IUSE="static-libs threads"
-
-DEPEND="sys-apps/texinfo"
-RDEPEND=""
-
-DOCS=( NEWS README docs/NOTES docs/TODO )
-
-src_prepare() {
-       # - Build objects twice, once -fPIC for shared.
-       # - Use DESTDIR.
-       # - Fix SONAME and NEEDED.
-       epatch "${FILESDIR}"/${P}-Makefile.in.patch
-       # - Broken test, always returns false.
-       epatch "${FILESDIR}"/${P}-cxx.patch
-       # - Add threads support.
-       use threads && epatch "${FILESDIR}"/${P}-threads.patch
-       # Respect CFLAGS/LDFLAGS. #337429
-       sed -i Makefile.in \
-               -e '/libdmalloc/ s:$(CC):& $(CFLAGS) $(LDFLAGS):g' \
-               || die "sed Makefile.in"
-       # - Run autoconf for -cxx.patch.
-       eautoconf
-}
-
-src_configure() {
-       econf --enable-cxx --enable-shlib $(use_enable threads)
-}
-
-src_compile() {
-       default
-
-       cd docs
-       makeinfo dmalloc.texi || die
-}
-
-src_test() {
-       emake heavy
-}
-
-src_install() {
-       default
-
-       newdoc ChangeLog.1 ChangeLog
-       insinto /usr/share/doc/${PF}
-       doins docs/dmalloc.pdf
-       dohtml RELEASE.html docs/dmalloc.html
-       doinfo docs/dmalloc.info
-
-       # add missing symlinks, lazy
-       dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so
-       dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so.${PV%%.*}
-
-       for lib in cxx th thcxx; do
-               dosym lib${PN}${lib}.so.${PV} /usr/$(get_libdir)/lib${PN}${lib}.so
-               dosym lib${PN}${lib}.so.${PV} \
-                       /usr/$(get_libdir)/lib${PN}${lib}.so.${PV%%.*}
-       done
-
-       if ! use static-libs; then
-               rm "${D}"/usr/$(get_libdir)/lib${PN}*.a || die
-       fi
-}
diff --git a/dev-libs/dmalloc/dmalloc-5.5.2-r6.ebuild b/dev-libs/dmalloc/dmalloc-5.5.2-r6.ebuild
deleted file mode 100644 (file)
index 89f15be..0000000
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit autotools eutils multilib toolchain-funcs
-
-DESCRIPTION="A Debug Malloc Library"
-HOMEPAGE="http://dmalloc.com"
-SRC_URI="http://dmalloc.com/releases/${P}.tgz"
-
-LICENSE="CC-BY-SA-3.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
-IUSE="static-libs threads"
-
-DEPEND="sys-apps/texinfo"
-RDEPEND=""
-
-DOCS=( NEWS README docs/NOTES docs/TODO )
-
-src_prepare() {
-       # - Build objects twice, once -fPIC for shared.
-       # - Use DESTDIR.
-       # - Fix SONAME and NEEDED.
-       epatch "${FILESDIR}"/${P}-Makefile.in.patch
-
-       # - Broken test, always returns false.
-       epatch "${FILESDIR}"/${P}-cxx.patch
-       epatch "${FILESDIR}"/${P}-ar.patch
-
-       # - Add threads support.
-       use threads && epatch "${FILESDIR}"/${P}-threads.patch
-
-       # strdup() strndup() macros
-       epatch "${FILESDIR}"/${P}-string-macros.patch
-
-       # Respect CFLAGS/LDFLAGS. #337429
-       sed -i \
-               -e '/libdmalloc/ s:$(CC):& $(CFLAGS) $(LDFLAGS):g' \
-               -e 's|ar cr|$(AR) cr|g' \
-               Makefile.in || die
-
-       # Run autoconf for -cxx.patch.
-       eautoconf
-}
-
-src_configure() {
-       tc-export AR
-       econf --enable-cxx --enable-shlib $(use_enable threads)
-}
-
-src_compile() {
-       default
-
-       cd docs
-       makeinfo dmalloc.texi || die
-}
-
-src_test() {
-       emake heavy
-}
-
-src_install() {
-       default
-
-       newdoc ChangeLog.1 ChangeLog
-       insinto /usr/share/doc/${PF}
-       doins docs/dmalloc.pdf
-       dohtml RELEASE.html docs/dmalloc.html
-       doinfo docs/dmalloc.info
-
-       # add missing symlinks, lazy
-       dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so
-       dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so.${PV%%.*}
-
-       for lib in cxx th thcxx; do
-               dosym lib${PN}${lib}.so.${PV} /usr/$(get_libdir)/lib${PN}${lib}.so
-               dosym lib${PN}${lib}.so.${PV} \
-                       /usr/$(get_libdir)/lib${PN}${lib}.so.${PV%%.*}
-       done
-
-       if ! use static-libs; then
-               rm "${ED}"/usr/$(get_libdir)/lib${PN}*.a || die
-       fi
-}