dev-db/qt5-sqlcipher: Version bump to 1.0.10.
authorUlrich Müller <ulm@gentoo.org>
Sat, 11 Apr 2020 16:32:51 +0000 (18:32 +0200)
committerUlrich Müller <ulm@gentoo.org>
Sat, 11 Apr 2020 18:47:00 +0000 (20:47 +0200)
Reported-by: Nils Freydank <holgersson@posteo.de>
Closes: https://bugs.gentoo.org/717084
Package-Manager: Portage-2.3.98, Repoman-2.3.22
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
dev-db/qt5-sqlcipher/Manifest
dev-db/qt5-sqlcipher/files/qt5-sqlcipher-1.0.10-install-path.patch [new file with mode: 0644]
dev-db/qt5-sqlcipher/qt5-sqlcipher-1.0.10.ebuild [new file with mode: 0644]

index 9081c6b40e81ab0e28c18052933a0ab81c514770..137e99733c48a383167e0ab82e0191e33199233c 100644 (file)
@@ -1,2 +1,3 @@
 DIST qt5-sqlcipher-1.0.1-qt-5.14.0.tar.xz 8248 BLAKE2B 0cc717deecf2ff1d212a5b510be0c57d5cdac6abf9dc5db8f5d69762adb2a0d79298aa0e2f453417a5aa5b242637094e7ebaf6d7fe777539e0f8896f6adc3709 SHA512 a61231756967f0596b3903db1ca40937f1140a3d06ff9b6b6f6a6195650c170e0d4f42a3d51ac3f3cb35f4e173b78986a8fb31ed7a7e01e125ae78c7dd851246
+DIST qt5-sqlcipher-1.0.10.tar.gz 245054 BLAKE2B edb36a47881e2d5801cf07cc9b6094ea53b9e0e595c0078d3a09b493979222a6ad655b074b015c0a152073e0f39d1e31ecb9e2021f7788dda04a0547cd47eddd SHA512 1a23da7d7c6de020ee0739154abe83f94208a3a6d385fd58eff38d3ea27ce51b37a66994e8ad0ff5102525c3573134f9b9362accf2032b7386ea174b12ea1338
 DIST qt5-sqlcipher-1.0.1_p20191025.tar.gz 200293 BLAKE2B 5a0c6401353bc1c9dc511ac585ebce8556742278c303032b3434116c5a778034df01a5133913f8eaac187863b91ef8432b20184b75882c738ed6d850682ac765 SHA512 9e5294ff4c25dc18ef83ecec6c7ef985fec73744f36b27d21591983eb9976b8a13151ef0a31ce3af9767ee3f6388b8f008404002345d328bf0094d03ca4dd8d0
diff --git a/dev-db/qt5-sqlcipher/files/qt5-sqlcipher-1.0.10-install-path.patch b/dev-db/qt5-sqlcipher/files/qt5-sqlcipher-1.0.10-install-path.patch
new file mode 100644 (file)
index 0000000..5485ae9
--- /dev/null
@@ -0,0 +1,14 @@
+--- qt5-sqlcipher-1.0.10-orig/CMakeLists.txt
++++ qt5-sqlcipher-1.0.10/CMakeLists.txt
+@@ -197,10 +197,7 @@
+               endif()
+       else()
+               message(WARNING "Packaging is not set up for this platform, either submit a ticket or change/add pathes yourself, if packaging is required.")
+-              INSTALL(TARGETS qsqlcipher DESTINATION sqldrivers)
+-              if (QSQLCIPHER_BUILD_TESTS)
+-                      INSTALL(TARGETS qsqlcipher-test DESTINATION bin)
+-              endif()
++              INSTALL(TARGETS qsqlcipher DESTINATION @LIBDIR@/qt5/plugins/sqldrivers)
+       endif()
+ else()
+       INSTALL(TARGETS qsqlcipher DESTINATION sqldrivers)
diff --git a/dev-db/qt5-sqlcipher/qt5-sqlcipher-1.0.10.ebuild b/dev-db/qt5-sqlcipher/qt5-sqlcipher-1.0.10.ebuild
new file mode 100644 (file)
index 0000000..2e1c483
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Qt SQL driver plugin for SQLCipher"
+HOMEPAGE="https://github.com/blizzard4591/qt5-sqlcipher"
+SRC_URI="https://github.com/blizzard4591/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1" # version 2.1 only
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-db/sqlcipher-3.4.1
+       >=dev-qt/qtcore-5.12.3:5=
+       >=dev-qt/qtsql-5.12.3:5=[sqlite] <dev-qt/qtsql-5.15:5=[sqlite]"
+DEPEND="${RDEPEND}"
+
+DOCS=(README.md)
+
+src_prepare() {
+       eapply "${FILESDIR}"/${P}-install-path.patch
+       sed -i -e "s/@LIBDIR@/$(get_libdir)/" CMakeLists.txt || die
+
+       local v=$(best_version dev-qt/qtsql:5)
+       v=$(ver_cut 1-3 ${v#*/qtsql-})
+       [[ -n ${v} ]] || die "could not determine qtsql version"
+       if ! [[ -d qt-file-cache/${v} ]]; then
+               local vc
+               case $(ver_cut 1-2 ${v}) in
+                       5.12) vc=5.12.5 ;;
+                       5.13) vc=5.13.2 ;;
+                       5.14) vc=5.14.1 ;;
+                       *) die "qtsql-${v} not supported" ;;
+               esac
+               elog "qtsql-${v} not in cache, using ${vc} instead"
+               cp -R qt-file-cache/${vc} qt-file-cache/${v} || die
+       fi
+
+       cmake-utils_src_prepare
+}
+
+src_test() {
+       cd "${BUILD_DIR}" || die
+       ./qsqlcipher-test || die
+}