www-client/opera-developer: Version 69.0.3623.0
authorJeroen Roovers <jer@gentoo.org>
Wed, 11 Mar 2020 08:39:25 +0000 (09:39 +0100)
committerJeroen Roovers <jer@gentoo.org>
Wed, 11 Mar 2020 08:45:20 +0000 (09:45 +0100)
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
www-client/opera-developer/Manifest
www-client/opera-developer/opera-developer-69.0.3623.0.ebuild [new file with mode: 0644]

index 0d53c7dbe2308e1d2a6cc7729dc7ebeab77062cb..c7984b2d0dafb5c9325decbd6c39315aa84a1c43 100644 (file)
@@ -1,3 +1,4 @@
 DIST opera-developer_68.0.3602.0_amd64.deb 67726784 BLAKE2B 1bc2593a291abb45aeba9e98bc86fb3741cd9da93ef635e8b6f08a963476cbff89fbd8d879ae048b4c7ee7bbc6d72750532679bab564ca9dc1029bfe92ff7302 SHA512 a5f2e42003ebeb892b7d8c22ebd4b9c9e8d94cd5f39eade4d3500819b96bd4d8ffec110c51a58fc5c2ca90d912885e25781ca5a362d3a07727b8561a653e55b8
 DIST opera-developer_68.0.3609.0_amd64.deb 67587784 BLAKE2B 75a12736f8eb852779e9e6a55d3be0f48b7bfd786d951ec96ec922473b2bfb8bac4c61fdd6cb27ce850f7afeaf367daca14a418aad8a992a6621bba660cdaed2 SHA512 5ce4ab56d448985f754c3d7fcb3aea03deaedc9cd532b9c0bceb355cc746c2e6ddcf27155473645da7778413a0397d182834d782cd4e2d2361e51a268184f148
 DIST opera-developer_68.0.3616.0_amd64.deb 67535652 BLAKE2B 38ab64f2a6ca0473157e07bf764fe389a32024de88fcb397ad5927e104c4cec4779b456e6d1afc8ec5ceb1f22c5c8e654cc2751785a6bcf5f599c237bc949eba SHA512 820f8a6dbbeb8837c2f4d9777959eb381cf3d6f58335c1e12e87d7ed87833318eadb3158f362362bb7c250407092ec0be877268cb1b448accd3e3c903675afc9
+DIST opera-developer_69.0.3623.0_amd64.deb 67847572 BLAKE2B b5a6e5807a0a0a354df4971b4c72b12c13e926edbd356fbb86d6b291a4eb9f87aa383d5b0b0adbc9d60de837d8729d0948da8213f7ed60bed98c8af7dd911c3e SHA512 f30250976748f4b11c4de7e67918974b2072eec8853300ba8c2f4e8ced3ab1921d7ba8f3ae31ec9d0332012c69596c500b05f733cdb35edd98c157f2d3fc8f73
diff --git a/www-client/opera-developer/opera-developer-69.0.3623.0.ebuild b/www-client/opera-developer/opera-developer-69.0.3623.0.ebuild
new file mode 100644 (file)
index 0000000..8376747
--- /dev/null
@@ -0,0 +1,115 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+CHROMIUM_LANGS="
+       be bg bn ca cs da de el en-GB es es-419 fi fil fr fr-CA hi hr hu id it
+       ja ko lt lv ms nb nl pl pt-BR pt-PT ro ru sk sr sv sw ta te th tr uk vi
+       zh-CN zh-TW
+"
+inherit chromium-2 multilib unpacker xdg-utils
+
+DESCRIPTION="A fast and secure web browser"
+HOMEPAGE="https://www.opera.com/"
+LICENSE="OPERA-2014"
+SLOT="0"
+SRC_URI_BASE="
+       https://download1.operacdn.com/pub/
+       https://download2.operacdn.com/pub/
+       https://download3.operacdn.com/pub/
+       https://download4.operacdn.com/pub/
+"
+SRC_URI="amd64? ("
+for uri in ${SRC_URI_BASE}; do
+SRC_URI+="
+       "${uri}${PN}/${PV}/linux/${PN}_${PV}_amd64.deb"
+"
+done
+SRC_URI+=")"
+KEYWORDS="~amd64"
+
+RDEPEND="
+       dev-libs/expat
+       dev-libs/glib:2
+       dev-libs/nspr
+       dev-libs/nss
+       gnome-base/gconf:2
+       media-libs/alsa-lib
+       media-libs/fontconfig
+       media-libs/freetype
+       net-misc/curl
+       net-print/cups
+       sys-apps/dbus
+       x11-libs/cairo
+       x11-libs/gdk-pixbuf
+       x11-libs/gtk+:3
+       x11-libs/libX11
+       x11-libs/libXScrnSaver
+       x11-libs/libXcomposite
+       x11-libs/libXcursor
+       x11-libs/libXdamage
+       x11-libs/libXext
+       x11-libs/libXfixes
+       x11-libs/libXi
+       x11-libs/libXrandr
+       x11-libs/libXrender
+       x11-libs/libXtst
+       x11-libs/libnotify
+       x11-libs/pango[X]
+"
+
+QA_PREBUILT="*"
+S=${WORKDIR}
+
+src_unpack() {
+       unpack_deb ${A}
+}
+
+pkg_setup() {
+       OPERA_HOME="usr/$(get_libdir)/${PN}"
+}
+
+src_prepare() {
+       default
+
+       case ${ARCH} in
+               amd64)
+                       mv usr/lib/x86_64-linux-gnu usr/$(get_libdir) || die
+                       rm -r usr/lib || die
+                       ;;
+               x86)
+                       mv usr/lib/i386-linux-gnu/${PN} usr/$(get_libdir)/ || die
+                       ;;
+       esac
+
+       mv usr/share/doc/${PN} usr/share/doc/${PF} || die
+       gunzip usr/share/doc/${PF}/changelog.gz || die
+
+       rm usr/bin/${PN} || die
+
+       pushd "${OPERA_HOME}/localization" > /dev/null || die
+       chromium_remove_language_paks
+       popd > /dev/null || die
+
+       sed -i \
+               -e 's|^TargetEnvironment|X-&|g' \
+               usr/share/applications/${PN}.desktop || die
+}
+
+src_install() {
+       mv * "${D}" || die
+       dosym ../$(get_libdir)/${PN}/${PN} /usr/bin/${PN}
+       fperms 4711 /usr/$(get_libdir)/${PN}/opera_sandbox
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+       xdg_mimeinfo_database_update
+}
+
+pkg_postinst() {
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+       xdg_mimeinfo_database_update
+}