www-servers/apache: process tmpfiles in pkg_postinst phase
authorThomas Deutschmann <whissi@gentoo.org>
Fri, 24 Aug 2018 16:34:06 +0000 (18:34 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Fri, 24 Aug 2018 16:34:26 +0000 (18:34 +0200)
Closes: https://bugs.gentoo.org/662544
Package-Manager: Portage-2.3.48, Repoman-2.3.10
RepoMan-Options: --force

www-servers/apache/apache-2.4.34-r2.ebuild

index db0368ea9f73991debc586ede78ccdc6010f113c..35e313631f5059c727e77c8b343db032e392c28a 100644 (file)
@@ -122,7 +122,7 @@ MODULE_CRITICAL="
        mime
        unixd
 "
-inherit apache-2 systemd toolchain-funcs
+inherit apache-2 systemd tmpfiles toolchain-funcs
 
 DESCRIPTION="The Apache Web Server"
 HOMEPAGE="https://httpd.apache.org/"
@@ -220,6 +220,9 @@ src_install() {
 
 pkg_postinst() {
        apache-2_pkg_postinst || die "apache-2_pkg_postinst failed"
+
+       tmpfiles_process apache.conf #662544
+
        # warnings that default config might not work out of the box
        local mod cmod
        for mod in ${MODULE_CRITICAL} ; do