Version bump. Also fixed the installation of docs.
authorLars Weiler <pylon@gentoo.org>
Sat, 11 Nov 2006 02:31:48 +0000 (02:31 +0000)
committerLars Weiler <pylon@gentoo.org>
Sat, 11 Nov 2006 02:31:48 +0000 (02:31 +0000)
Package-Manager: portage-2.1.2_rc1-r5

app-cdr/cdrkit/ChangeLog
app-cdr/cdrkit/cdrkit-1.0_pre5.ebuild [new file with mode: 0644]
app-cdr/cdrkit/files/digest-cdrkit-1.0_pre5 [new file with mode: 0644]

index 6721a774b2c06b4fa8e11a433f20373adfaaea94..0c8d0848e2a9431ec0358c773700ddbd436c43b8 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for app-cdr/cdrkit
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrkit/ChangeLog,v 1.9 2006/10/31 15:21:03 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrkit/ChangeLog,v 1.10 2006/11/11 02:31:48 pylon Exp $
+
+*cdrkit-1.0_pre5 (11 Nov 2006)
+
+  11 Nov 2006; Lars Weiler <pylon@gentoo.org> -cdrkit-1.0_pre3.ebuild,
+  +cdrkit-1.0_pre5.ebuild:
+  Version bump.  Also fixed the installation of docs.
 
 *cdrkit-1.0_pre4-r1 (31 Oct 2006)
 
diff --git a/app-cdr/cdrkit/cdrkit-1.0_pre5.ebuild b/app-cdr/cdrkit/cdrkit-1.0_pre5.ebuild
new file mode 100644 (file)
index 0000000..1e9831f
--- /dev/null
@@ -0,0 +1,70 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdrkit/cdrkit-1.0_pre5.ebuild,v 1.1 2006/11/11 02:31:48 pylon Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}-${PV/_/}"
+
+DESCRIPTION="Cdrkit is a fork of the latest complete free cdrtools sources."
+HOMEPAGE="http://debburn.alioth.debian.org/"
+SRC_URI="http://debburn.alioth.debian.org/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc
+       >=dev-util/cmake-2.4
+       !app-cdr/cdrtools
+       sys-libs/libcap"
+
+PROVIDE="virtual/cdrtools"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+       cmake \
+               -DCMAKE_INSTALL_PREFIX=/usr \
+               -DCMAKE_C_COMPILER=$(which $(tc-getCC))
+
+       emake || die
+}
+
+src_install() {
+       make DESTDIR=${D} install || die
+
+       dosym /usr/bin/wodim /usr/bin/cdrecord
+
+       cd ${S}
+       dodoc ABOUT Changelog FAQ FORK START TODO VERSION
+
+       cd ${S}/doc/READMEs
+       dodoc README*
+
+       cd ${S}/doc/wodim
+       dodoc README*
+
+       cd ${S}/doc/cdda2wav
+       docinto cdda2wav
+       dodoc FAQ Frontends HOWTOUSE README TODO
+
+       cd ${S}/doc/mkisofs
+       docinto mkisofs
+       dodoc *
+
+       cd ${S}/doc/plattforms/
+       docinto platforms
+       dodoc README.{linux,parallel}
+
+       cd ${S}
+       insinto /etc
+       newins cdrecord/wodim.dfl wodim.conf
+
+       cd ${S}
+       insinto /usr/include/scsilib
+       doins include/*.h
+       insinto /usr/include/scsilib/scg
+       doins include/scg/*.h
+}
diff --git a/app-cdr/cdrkit/files/digest-cdrkit-1.0_pre5 b/app-cdr/cdrkit/files/digest-cdrkit-1.0_pre5
new file mode 100644 (file)
index 0000000..b69b8be
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 ee2a034861a6eb835e606f49655e48f5 cdrkit-1.0pre5.tar.gz 1450417
+RMD160 75e49c97e893b948d816ff8bbbc11fa2b3cc556c cdrkit-1.0pre5.tar.gz 1450417
+SHA256 863573d188c0cc588c151282f2983ce59af0985e04c77ccc90e25f67e0e420b5 cdrkit-1.0pre5.tar.gz 1450417