dev-vcs/mercurial: drop 'strip-flags' parameters, bug #712594
authorSergei Trofimovich <slyfox@gentoo.org>
Sun, 15 Mar 2020 09:28:00 +0000 (09:28 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Sun, 15 Mar 2020 09:28:22 +0000 (09:28 +0000)
This is not a fix for bug #712594.

The code change only gets ebuild to the state it was before
f8669c1089dd9962d946c7be46 "flag-o-matic.eclass: add assertions
around argument counts" was submitted.

We'll need a proper fix. I've left a TODO in ebuild.

Bug: https://bugs.gentoo.org/712594
Package-Manager: Portage-2.3.94, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-vcs/mercurial/mercurial-4.6.2.ebuild
dev-vcs/mercurial/mercurial-4.9-r2.ebuild
dev-vcs/mercurial/mercurial-4.9.1.ebuild
dev-vcs/mercurial/mercurial-5.0.2.ebuild
dev-vcs/mercurial/mercurial-5.1.2.ebuild
dev-vcs/mercurial/mercurial-5.2.2-r1.ebuild
dev-vcs/mercurial/mercurial-9999.ebuild

index eb2b0fe3fdcd80085c8702c8ce45f41a577fbae4..135710a8f27a80442ee70e10b938f79e77b0d7ec 100644 (file)
@@ -41,7 +41,7 @@ python_prepare_all() {
 }
 
 python_configure_all() {
-       strip-flags -ftracer -ftree-vectorize
+       strip-flags # was '-ftracer -ftree-vectorize', TODO: see bug #712594
        # Note: make it impl-conditional if py3 is supported
        append-flags -fno-strict-aliasing
 
index 2bb6186ecadb746e9af2c1d413b782c3667f3a05..25fa556dc7ae89dfbdcdc0ad77034081b37ba0b3 100644 (file)
@@ -49,7 +49,7 @@ python_prepare_all() {
 }
 
 python_configure_all() {
-       strip-flags -ftracer -ftree-vectorize
+       strip-flags # was '-ftracer -ftree-vectorize', TODO: see bug #712594
        # Note: make it impl-conditional if py3 is supported
        append-flags -fno-strict-aliasing
 
index 6d3bef63979d6aa1ef1253706f877d34b669c83c..c50921ab4f38e4578d07897cfe065057484297df 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -49,7 +49,7 @@ python_prepare_all() {
 }
 
 python_configure_all() {
-       strip-flags -ftracer -ftree-vectorize
+       strip-flags # was '-ftracer -ftree-vectorize', TODO: see bug #712594
        # Note: make it impl-conditional if py3 is supported
        append-flags -fno-strict-aliasing
 
index c3f5137de8f66414c684f47bfcfcba7bd36005b3..8e116e6682033b1ccafc3a0fc94a0d14e753a937 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -49,7 +49,7 @@ python_prepare_all() {
 }
 
 python_configure_all() {
-       strip-flags -ftracer -ftree-vectorize
+       strip-flags # was '-ftracer -ftree-vectorize', TODO: see bug #712594
        # Note: make it impl-conditional if py3 is supported
        append-flags -fno-strict-aliasing
 
index 7ae34dee8a9e7949b5a7f41a1684d517c9808249..24db3c875e13c9810b5d68aed79e0d8c7380b3ff 100644 (file)
@@ -49,7 +49,7 @@ python_prepare_all() {
 }
 
 python_configure_all() {
-       strip-flags -ftracer -ftree-vectorize
+       strip-flags # was '-ftracer -ftree-vectorize', TODO: see bug #712594
        # Note: make it impl-conditional if py3 is supported
        append-flags -fno-strict-aliasing
 
index 474c441d67787161ea87aec7352bb3bd5ddf6fa5..051a9978464b932faabfcebd3e218177a7d379d2 100644 (file)
@@ -55,7 +55,7 @@ python_prepare_all() {
 }
 
 python_compile() {
-       strip-flags -ftracer -ftree-vectorize
+       strip-flags # was '-ftracer -ftree-vectorize', TODO: see bug #712594
        python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
        distutils-r1_python_compile build_ext --no-zstd
 }
index 8c12d545eb8702baed063de2a1755202d7cff6ff..8a93eddd65bfa934a627b3c0bf772bdbbc6bbaf6 100644 (file)
@@ -57,7 +57,7 @@ python_prepare_all() {
 }
 
 python_compile() {
-       strip-flags -ftracer -ftree-vectorize
+       strip-flags # was '-ftracer -ftree-vectorize', TODO: see bug #712594
        python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
        distutils-r1_python_compile build_ext --no-zstd
 }