dev-python/sabyenc: fix tests with pytest-3.2.2
authorJustin Bronder <jsbronder@gentoo.org>
Wed, 3 Jan 2018 17:08:44 +0000 (12:08 -0500)
committerJustin Bronder <jsbronder@gentoo.org>
Wed, 3 Jan 2018 17:08:44 +0000 (12:08 -0500)
https://github.com/sabnzbd/sabyenc/pull/7

Package-Manager: Portage-2.3.13, Repoman-2.3.3

dev-python/sabyenc/sabyenc-3.3.1.ebuild

index 0a4c2171daf493504e744894599c4f09400c1fae..f464f4481104f96049b879d37166131eaa566c16 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -21,5 +21,10 @@ DEPEND="
 DOCS=( CHANGES.md README.md doc/yenc-draft.1.3.txt )
 
 python_test() {
+       # https://github.com/sabnzbd/sabyenc/pull/7
+       cat <<-EOF > pytest.ini
+               [pytest]
+               norecursedirs = yencfiles
+       EOF
        pytest -v || die "Test failed."
 }