dev-python/sphinx-testing: Bump to 1.0.1, EAPI=7, Py3.7
authorMichał Górny <mgorny@gentoo.org>
Sun, 14 Jul 2019 09:23:29 +0000 (11:23 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 14 Jul 2019 12:26:21 +0000 (14:26 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/sphinx-testing/Manifest
dev-python/sphinx-testing/sphinx-testing-1.0.1.ebuild [new file with mode: 0644]

index d12617ea84067c449ea8f39bfcbc7ad59b949066..df086e6c0f273b7710133a9e3d0f031e88929f22 100644 (file)
@@ -1 +1,2 @@
 DIST sphinx-testing-0.7.2.tar.gz 11040 BLAKE2B 503e38eabfe8dbe28942f9165a83db2dec0f9ac52e1e55f7298848b7a6b55244e1b5623bfda7f4e1380eab16ef81cf51c6bc11e919a8b45506f17759ae0ee181 SHA512 d267c74d97443db2df69914a825da969021e37fc61b8a664ef382504fa826387a95230bf9259b58c6f26721f33985fa2168d2714342a2166b59740cf1b3ad724
+DIST sphinx-testing-1.0.1.tar.gz 11513 BLAKE2B 46ede243507a0d90b2ad4b918deadb818491bb0ed15ce41886040c52650f9fd348ff57c03766fd1e7719bbb54726f8915e091cf94a5396da946102ca49fd07b2 SHA512 2d377c0c6fe8e34a463b35e96938507a3ca35fa06cd19a2682eb55825e1b88982a80a02ebb9a02a47f11ca5e8fe6a5b9e5c8114d955fa3b774e0148e82121818
diff --git a/dev-python/sphinx-testing/sphinx-testing-1.0.1.ebuild b/dev-python/sphinx-testing/sphinx-testing-1.0.1.ebuild
new file mode 100644 (file)
index 0000000..1a69f9f
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Testing utility classes and functions for Sphinx extensions"
+HOMEPAGE="https://github.com/sphinx-doc/sphinx-testing"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+       dev-python/sphinx[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/nose[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)
+       )"
+
+python_test() {
+       # NB: while tests don't stricly use nose, they rely on some side
+       # effects of using it
+       nosetests -v || die "Tests fail with ${EPYTHON}"
+}