dev-lang/go: 1.12.9 bump
authorWilliam Hubbs <william.hubbs@sony.com>
Tue, 20 Aug 2019 16:43:42 +0000 (11:43 -0500)
committerWilliam Hubbs <williamh@gentoo.org>
Tue, 20 Aug 2019 17:11:55 +0000 (12:11 -0500)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: William Hubbs <williamh@gentoo.org>
dev-lang/go/Manifest
dev-lang/go/go-1.12.9.ebuild [new file with mode: 0644]

index b241e6240f5adec95f8c48ede4468f01bdd068ca..1b9ec08f9baea43a497757a28817931a298bf561 100644 (file)
@@ -16,3 +16,4 @@ DIST go1.12.5.src.tar.gz 21971348 BLAKE2B 7de8db4a6c4cd9e1883fbf28357fe99ad9f43f
 DIST go1.12.6.src.tar.gz 21975398 BLAKE2B 05c183baf2e6544b039cff33abb7c5d66a50a0a7cadaa16032a3dc3793bfa27e82c4598dbb700bf7f90ba2ce2639bb60484e61e50fc154d8184d4874954b81e4 SHA512 431a0b916ce2e64d816808a04bc3bf028e955538ab55c571021c08e599781ae344487a55e119bb3aae3d32f84cd83e2c176dc72d336b95da0352edffeab07a48
 DIST go1.12.7.src.tar.gz 21976647 BLAKE2B bf0c723f1e02048d91844c7b8908500c83442a8ab7ceeaacdb37d7204f72d80331eab44de54f99411479be8e645b2626fb8a34df0cedbd75fa57c4e1d84d493a SHA512 f84c6b89dea9df21f0efa07564eb80baeee5bc2d68cced5fd645ebb32e9317e60b657afe011c81e7739d8a93e4b4dafa0b4f78431a009d36e05de55f89ed0fd6
 DIST go1.12.8.src.tar.gz 21978756 BLAKE2B 65258c101d729bbd82f69ba4286ba8e64f9d3128be97243374d442dfcc4033f1238bb57530a34dc0142f55cc8f2692efab65452286c4769f24e8aa3a4a80abd1 SHA512 193a9b08752aa2479c19f5b56fdfe2296c7e6097e0c583290f0fce754ac7571e2ff345f66b69774d8e22f2caa147a3dc15658148017b09e5e7f49fd4569373d4
+DIST go1.12.9.src.tar.gz 21979950 BLAKE2B dca7e3afcabd513c4b8193e93c0a1ed1a2326dccfce9b909d97b3731fffbe7e26712ab164645e06a316baa949b1e0b14a2fea8d23e6f90fd5b72afa0d15b432b SHA512 57041e7fb767f528aa9fc2592d205d3a7c120c73f92dc8d91f17f816e12aa6152c8421b333081800a5f50b1bb656f203a25faf8ed92c69a6ec164ce0a5619c13
diff --git a/dev-lang/go/go-1.12.9.ebuild b/dev-lang/go/go-1.12.9.ebuild
new file mode 100644 (file)
index 0000000..a6151a8
--- /dev/null
@@ -0,0 +1,246 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+
+MY_PV=${PV/_/}
+
+inherit toolchain-funcs
+
+BOOTSTRAP_VERSION="bootstrap-1.8"
+BOOTSTRAP_DIST="https://dev.gentoo.org/~williamh/dist"
+BOOTSTRAP_URI="
+       ${BOOTSTRAP_DIST}/go-linux-amd64-${BOOTSTRAP_VERSION}.tbz
+       ${BOOTSTRAP_DIST}/go-linux-arm-${BOOTSTRAP_VERSION}.tbz
+       ${BOOTSTRAP_DIST}/go-linux-arm64-${BOOTSTRAP_VERSION}.tbz
+       ${BOOTSTRAP_DIST}/go-linux-ppc64-${BOOTSTRAP_VERSION}.tbz
+       ${BOOTSTRAP_DIST}/go-linux-ppc64le-${BOOTSTRAP_VERSION}.tbz
+       ${BOOTSTRAP_DIST}/go-linux-s390x-${BOOTSTRAP_VERSION}.tbz
+       ${BOOTSTRAP_DIST}/go-linux-386-${BOOTSTRAP_VERSION}.tbz
+       ${BOOTSTRAP_DIST}/go-freebsd-amd64-${BOOTSTRAP_VERSION}.tbz
+       ${BOOTSTRAP_DIST}/go-freebsd-386-${BOOTSTRAP_VERSION}.tbz
+       ${BOOTSTRAP_DIST}/go-darwin-amd64-${BOOTSTRAP_VERSION}.tbz
+       ${BOOTSTRAP_DIST}/go-solaris-amd64-${BOOTSTRAP_VERSION}.tbz
+"
+
+case ${PV}  in
+*9999*)
+       EGIT_REPO_URI="https://github.com/golang/go.git"
+       inherit git-r3
+       ;;
+*)
+       SRC_URI="https://storage.googleapis.com/golang/go${MY_PV}.src.tar.gz "
+       S="${WORKDIR}"/go
+       case ${PV} in
+       *_beta*|*_rc*) ;;
+       *)
+               KEYWORDS="-* ~amd64 ~arm ~arm64 ~ppc64 ~s390 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+               # The upstream tests fail under portage but pass if the build is
+               # run according to their documentation [1].
+               # I am restricting the tests on released versions until this is
+               # solved.
+               # [1] https://golang.org/issues/18442
+               RESTRICT="test"
+               ;;
+       esac
+esac
+
+# If gccgo or a previously installed version of dev-lang/go is not being
+# used to build Go, there is no way to know the architecture or operating system
+# of the build machine, so we need to download all of our bootstrap
+# archives to allow this ebuild to work under crossdev.
+#
+# https://bugs.gentoo.org/671394
+SRC_URI+="!gccgo? ( !system-bootstrap? ( ${BOOTSTRAP_URI} ) )"
+
+DESCRIPTION="A concurrent garbage collected and typesafe programming language"
+HOMEPAGE="https://golang.org"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE="gccgo system-bootstrap"
+
+BDEPEND="gccgo? ( >=sys-devel/gcc-5[go] )"
+RDEPEND="!<dev-go/go-tools-0_pre20150902"
+
+# These test data objects have writable/executable stacks.
+QA_EXECSTACK="
+       usr/lib/go/src/debug/elf/testdata/*.obj
+       usr/lib/go/src/*.gox
+       "
+
+# Do not complain about CFLAGS, etc, since Go doesn't use them.
+QA_FLAGS_IGNORED='.*'
+
+REQUIRES_EXCLUDE="/usr/lib/go/src/debug/elf/testdata/*"
+
+# The tools in /usr/lib/go should not cause the multilib-strict check to fail.
+QA_MULTILIB_PATHS="usr/lib/go/pkg/tool/.*/.*"
+
+# Do not strip this package. Stripping is unsupported upstream and may
+# fail.
+RESTRICT+=" strip"
+
+DOCS=(
+AUTHORS
+CONTRIBUTING.md
+CONTRIBUTORS
+PATENTS
+README.md
+)
+
+go_arch()
+{
+       # By chance most portage arch names match Go
+       local portage_arch=$(tc-arch $@)
+       case "${portage_arch}" in
+               x86)    echo 386;;
+               x64-*)  echo amd64;;
+               ppc64) [[ $(tc-endian $@) = big ]] && echo ppc64 || echo ppc64le ;;
+               s390) echo s390x ;;
+               *)              echo "${portage_arch}";;
+       esac
+}
+
+go_arm()
+{
+       case "${1:-${CHOST}}" in
+               armv5*) echo 5;;
+               armv6*) echo 6;;
+               armv7*) echo 7;;
+               *)
+                       die "unknown GOARM for ${1:-${CHOST}}"
+                       ;;
+       esac
+}
+
+go_os()
+{
+       case "${1:-${CHOST}}" in
+               *-linux*)       echo linux;;
+               *-darwin*)      echo darwin;;
+               *-freebsd*)     echo freebsd;;
+               *-netbsd*)      echo netbsd;;
+               *-openbsd*)     echo openbsd;;
+               *-solaris*)     echo solaris;;
+               *-cygwin*|*-interix*|*-winnt*)
+                       echo windows
+                       ;;
+               *)
+                       die "unknown GOOS for ${1:-${CHOST}}"
+                       ;;
+       esac
+}
+
+go_tuple()
+{
+       echo "$(go_os $@)_$(go_arch $@)"
+}
+
+go_cross_compile()
+{
+       [[ $(go_tuple ${CBUILD}) != $(go_tuple) ]]
+}
+
+pkg_pretend()
+{
+       # make.bash does not understand cross-compiling a cross-compiler
+       if [[ $(go_tuple) != $(go_tuple ${CTARGET}) ]]; then
+               die "CHOST CTARGET pair unsupported: CHOST=${CHOST} CTARGET=${CTARGET}"
+       fi
+       [[ ${MERGE_TYPE} != binary ]] &&
+               use system-bootstrap && ! has_version "dev-lang/go" &&
+               die "dev-lang/go must be installed to use the system-bootstrap use flag"
+}
+
+src_unpack()
+{
+       if [[ ${PV} = 9999 ]]; then
+               git-r3_src_unpack
+       else
+               unpack "go${MY_PV}.src.tar.gz"
+       fi
+       use gccgo || use system-bootstrap ||
+               unpack "go-$(go_os ${CBUILD})-$(go_arch ${CBUILD})-${BOOTSTRAP_VERSION}.tbz"
+}
+
+src_compile()
+{
+       export GOROOT_BOOTSTRAP="${WORKDIR}"/go-$(go_os ${CBUILD})-$(go_arch ${CBUILD})-bootstrap
+       if use gccgo; then
+               mkdir -p "${GOROOT_BOOTSTRAP}/bin" || die
+               local go_binary=$(gcc-config --get-bin-path)/go-$(gcc-major-version)
+               [[ -x ${go_binary} ]] || go_binary=$(
+                       find "${EPREFIX}"/usr/${CHOST}/gcc-bin/*/go-$(gcc-major-version) |
+                               sort -V | tail -n1)
+               [[ -x ${go_binary} ]] ||
+                       die "go-$(gcc-major-version): command not found"
+               ln -s "${go_binary}" "${GOROOT_BOOTSTRAP}/bin/go" || die
+       elif use system-bootstrap; then
+               export GOROOT_BOOTSTRAP="${EPREFIX}"/usr/lib/go
+       fi
+       export GOROOT_FINAL="${EPREFIX}"/usr/lib/go
+       export GOROOT="$(pwd)"
+       export GOBIN="${GOROOT}/bin"
+
+       # Go's build script does not use BUILD/HOST/TARGET consistently. :(
+       export GOHOSTARCH=$(go_arch ${CBUILD})
+       export GOHOSTOS=$(go_os ${CBUILD})
+       export CC=$(tc-getBUILD_CC)
+
+       export GOARCH=$(go_arch)
+       export GOOS=$(go_os)
+       export CC_FOR_TARGET=$(tc-getCC)
+       export CXX_FOR_TARGET=$(tc-getCXX)
+       if [[ ${ARCH} == arm ]]; then
+               export GOARM=$(go_arm)
+       fi
+
+       cd src
+       ./make.bash || die "build failed"
+}
+
+src_test()
+{
+       go_cross_compile && return 0
+
+       cd src
+       PATH="${GOBIN}:${PATH}" \
+       ./run.bash -no-rebuild || die "tests failed"
+}
+
+src_install()
+{
+       local bin_path f x
+
+       dodir /usr/lib/go
+
+       # There is a known issue which requires the source tree to be installed [1].
+       # Once this is fixed, we can consider using the doc use flag to control
+       # installing the doc and src directories.
+       # [1] https://golang.org/issue/2775
+       #
+       # deliberately use cp to retain permissions
+       cp -R api bin doc lib pkg misc src test "${ED}"/usr/lib/go
+       if go_cross_compile; then
+               bin_path="bin/$(go_tuple)"
+       else
+               bin_path=bin
+       fi
+       for x in ${bin_path}/*; do
+               f=${x##*/}
+               dosym ../lib/go/${bin_path}/${f} /usr/bin/${f}
+       done
+       einstalldocs
+
+       if [[ ${CHOST} == *-darwin* ]] ; then
+               # fix install_name for test object (binutils_test) on Darwin, it
+               # is never used in real circumstances
+               local libmac64="${EPREFIX}"/usr/lib/go/src/cmd/vendor/github.com/
+                     libmac64+=google/pprof/internal/binutils/testdata/lib_mac_64
+               install_name_tool -id "${libmac64}" "${D}${libmac64}"
+       fi
+}