sys-apps/conspy: Version 1.14
authorJeroen Roovers <jer@gentoo.org>
Thu, 31 Oct 2019 10:37:40 +0000 (11:37 +0100)
committerJeroen Roovers <jer@gentoo.org>
Thu, 31 Oct 2019 10:38:04 +0000 (11:38 +0100)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Fixes: https://bugs.gentoo.org/690238
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
sys-apps/conspy/Manifest
sys-apps/conspy/conspy-1.14.ebuild [new file with mode: 0644]
sys-apps/conspy/files/conspy-1.14-tinfo.patch [new file with mode: 0644]

index 1ff2956ea3ed519bc886b8a575d54d234c3c88ec..1cf2e9873c2486d78238a592e802efec083e3947 100644 (file)
@@ -1 +1,2 @@
 DIST conspy-1.10.tar.gz 25211 BLAKE2B 2cb2d2c02bc38ab26bc2f08737c7e2f87dacb4fd04240bda63900e0b9018f98d28b2ee2fa00dba5ca931d59b823a72f2e0dd282828b081b31d91dd64c652dbef SHA512 f22ddff140935f767bff34c8c274ff088ebae049ac61c543ad37fa126bbab2e1cec72bdd93f51cb513d00368b909935491d06a36dbff215f17cdea7a658dbad2
+DIST conspy-1.14.tar.gz 26637 BLAKE2B 6fd4e3c35bf978ca7041aac0de23745a5c7cb200e4b29ec841cc195ea75194ed9a65ef46c85fc40b549ca68593ddab1af39499725880da403a602f97650982cd SHA512 46c25770e399c46de5aadcfbf4cff4ab5bc0f83771d6930b5752b9493f8c6864cc86d787ef6f297a00944e65987a56f6bf2cf99975eff689864745c0eef45b0d
diff --git a/sys-apps/conspy/conspy-1.14.ebuild b/sys-apps/conspy/conspy-1.14.ebuild
new file mode 100644 (file)
index 0000000..1185be8
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Remote control for Linux virtual consoles"
+HOMEPAGE="http://conspy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-1/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       sys-libs/ncurses:0=
+"
+DEPEND="
+       ${RDEPEND}
+"
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.14-tinfo.patch
+)
+DOCS=(
+       ChangeLog.txt README.txt ${PN}.html
+)
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_install() {
+       default
+}
diff --git a/sys-apps/conspy/files/conspy-1.14-tinfo.patch b/sys-apps/conspy/files/conspy-1.14-tinfo.patch
new file mode 100644 (file)
index 0000000..55ee90b
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -11,6 +11,7 @@
+ AC_HEADER_STDC
+ AC_CHECK_HEADERS([fcntl.h getopt.h stdarg.h stdlib.h string.h sys/ioctl.h sys/time.h termios.h unistd.h])
+ AC_CHECK_LIB(ncurses, initscr)
++AC_SEARCH_LIBS(putp, tinfo)
+ # Checks for typedefs, structures, and compiler characteristics.
+ AC_HEADER_TIME