media-sound/guayadeque: fixed 0.4.5_p20170110
authorMiroslav Šulc <fordfrog@gentoo.org>
Sat, 28 Dec 2019 17:16:01 +0000 (18:16 +0100)
committerMiroslav Šulc <fordfrog@gentoo.org>
Sat, 28 Dec 2019 17:16:20 +0000 (18:16 +0100)
Closes: https://bugs.gentoo.org/681632
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
media-sound/guayadeque/files/guayadeque-0.4.5_p20170110-missing-aui-component.patch [new file with mode: 0644]
media-sound/guayadeque/guayadeque-0.4.5_p20170110.ebuild

diff --git a/media-sound/guayadeque/files/guayadeque-0.4.5_p20170110-missing-aui-component.patch b/media-sound/guayadeque/files/guayadeque-0.4.5_p20170110-missing-aui-component.patch
new file mode 100644 (file)
index 0000000..69a6e8b
--- /dev/null
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e46d921..13e4ffa 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -32,7 +32,7 @@ SET( SEARCH_LIBS
+ SET( wxWidgets_USE_LIBS base core adv net html xml aui qa )
+-FIND_PACKAGE( wxWidgets )
++FIND_PACKAGE( wxWidgets COMPONENTS base core adv net html xml aui qa REQUIRED )
+ IF( NOT wxWidgets_FOUND)
+     MESSAGE( FATAL_ERROR "wxWidgets not found!" )
index 53d52ddcc332e35875ca82c14346f32f3eab43d4..72dbae26c33481de3534b57c359cd97148c87c50 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -48,6 +48,10 @@ DEPEND="${RDEPEND}
        sys-devel/gettext
        virtual/pkgconfig"
 
+PATCHES=(
+       "${FILESDIR}/${PF}-missing-aui-component.patch"
+)
+
 # echo $(cat po/CMakeLists.txt | grep ADD_SUBDIRECTORY | sed 's#ADD_SUBDIRECTORY( \(\w\+\) )#\1#')
 LANGS=( bg ca_ES cs de el es fr hr hu is it ja nb nl pl pt pt_BR ru sk sr sr@latin sv th tr uk )