dev-perl/MogileFS-Server: disable automatic tests
authorRobin H. Johnson <robbat2@gentoo.org>
Fri, 8 Nov 2019 01:11:06 +0000 (17:11 -0800)
committerRobin H. Johnson <robbat2@gentoo.org>
Fri, 8 Nov 2019 14:23:05 +0000 (06:23 -0800)
Fix the test deps, but also disable tests.

The SQLite test suite no longer completes for permission reasons, and we
cannot rely on being able to use a system MySQL or PostGreSQL.

Fixes: https://bugs.gentoo.org/show_bug.cgi?id=699560
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
dev-perl/MogileFS-Server/MogileFS-Server-2.720.0-r1.ebuild

index 691d30b4fd8fc552db3b9a91ec1bacd4c1657e98..1ab8f1f30f2bb689d39a4140ac3d616edf8eae6b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -10,7 +10,8 @@ inherit user perl-module
 DESCRIPTION="Server for the MogileFS distributed file system"
 HOMEPAGE="http://www.danga.com/mogilefs/ ${HOMEPAGE}"
 
-IUSE="mysql sqlite postgres"
+IUSE="mysql sqlite test postgres"
+REQUIRED_USE="test? ( sqlite ) || ( mysql sqlite postgres )"
 
 SLOT="0"
 LICENSE="|| ( Artistic GPL-2 )"
@@ -35,9 +36,9 @@ RDEPEND="dev-perl/Net-Netmask
 DEPEND="${RDEPEND}"
 
 PATCHES=(
-       "${FILESDIR}/${P}-gentoo-init-conf.patch"
+       "${FILESDIR}/${PN}-2.720.0-gentoo-init-conf.patch"
 )
-DIST_TEST="do"
+DIST_TEST="never"
 
 MOGILE_USER="mogile"
 
@@ -75,3 +76,7 @@ pkg_postinst() {
        chmod 640 "${ROOT}"/etc/mogilefs/{mogilefsd,mogstored}.conf
        chown root:${MOGILE_USER} "${ROOT}"/etc/mogilefs/{mogilefsd,mogstored}.conf
 }
+
+#src_test() {
+#      emake test MOGTEST_DBUSER=mogile MOGTEST_DBNAME=tmp_mogiletest MOGTEST_DBTYPE=SQLite
+#}