dev-util/cpptest: Support USE=-static-libs
authorSebastian Pipping <sping@gentoo.org>
Wed, 20 May 2020 23:18:44 +0000 (01:18 +0200)
committerSebastian Pipping <sping@gentoo.org>
Wed, 20 May 2020 23:19:33 +0000 (01:19 +0200)
Closes: https://bugs.gentoo.org/724290
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.99, Repoman-2.3.22

dev-util/cpptest/cpptest-2.0.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-util/cpptest/cpptest-2.0.0-r1.ebuild b/dev-util/cpptest/cpptest-2.0.0-r1.ebuild
new file mode 100644 (file)
index 0000000..e981527
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Simple but powerful unit testing framework for C++"
+HOMEPAGE="https://github.com/cpptest/cpptest"
+SRC_URI="https://github.com/cpptest/cpptest/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="1"  # for soversion 1.x.x
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="doc static-libs"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND="!dev-util/cpptest:0"
+
+DOCS=( AUTHORS BUGS NEWS README )
+
+src_configure() {
+       econf $(use_enable doc) $(use_enable static-libs static)
+}
+
+src_install() {
+       default
+       find "${D}" -name '*.la' -delete || die
+}