Initial ebuild.
authorSebastian Bergmann <sebastian@gentoo.org>
Tue, 28 Feb 2006 11:36:24 +0000 (11:36 +0000)
committerSebastian Bergmann <sebastian@gentoo.org>
Tue, 28 Feb 2006 11:36:24 +0000 (11:36 +0000)
Package-Manager: portage-2.1_pre5

dev-php4/pecl-radius/ChangeLog [new file with mode: 0644]
dev-php4/pecl-radius/Manifest [new file with mode: 0644]
dev-php4/pecl-radius/files/digest-pecl-radius-1.2.4 [new file with mode: 0644]
dev-php4/pecl-radius/metadata.xml [new file with mode: 0644]
dev-php4/pecl-radius/pecl-radius-1.2.4.ebuild [new file with mode: 0644]

diff --git a/dev-php4/pecl-radius/ChangeLog b/dev-php4/pecl-radius/ChangeLog
new file mode 100644 (file)
index 0000000..6a69580
--- /dev/null
@@ -0,0 +1,10 @@
+# ChangeLog for dev-php4/pecl-radius
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-radius/ChangeLog,v 1.1 2006/02/28 11:36:24 sebastian Exp $
+
+*pecl-radius-1.2.4 (28 Feb 2006)
+
+  28 Feb 2006; Sebastian Bergmann <sebastian@gentoo.org> +metadata.xml,
+  +pecl-radius-1.2.4.ebuild:
+  Initial ebuild.
+
diff --git a/dev-php4/pecl-radius/Manifest b/dev-php4/pecl-radius/Manifest
new file mode 100644 (file)
index 0000000..e1c4490
--- /dev/null
@@ -0,0 +1,22 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 3bb03a789d365091f4f8cf359064feb8 ChangeLog 370
+RMD160 d2d7f33ecdf832a4ff51b62f350647ed177e0d93 ChangeLog 370
+SHA256 f30c5a413b8af3670374af51bd01412b1179db479cd41f37aa81766a98395747 ChangeLog 370
+MD5 fe2b74003267219092ef70b10bd05984 files/digest-pecl-radius-1.2.4 226
+RMD160 6ff8e3d898e84198a1064eaeb5e3733122c53d3f files/digest-pecl-radius-1.2.4 226
+SHA256 f07f0832027367259ad61c275766d220f79353c6c67a964bf81fe4fe33096aba files/digest-pecl-radius-1.2.4 226
+MD5 c58d07ca1c1235bbad9bccaec96fc062 metadata.xml 157
+RMD160 a98db3a086fae3c09a903dadbc05f60443ec4b1a metadata.xml 157
+SHA256 54f8878ca0228e380abbaa4b529806b5533a6b9b51b3b16c0909e906586a91a1 metadata.xml 157
+MD5 2ac77d99633f6250b57c084c08e2839e pecl-radius-1.2.4.ebuild 596
+RMD160 35ceae0ff4054ef2709cfa5ce0af49211384a5f9 pecl-radius-1.2.4.ebuild 596
+SHA256 c9a8650ac1c4754d12b5c69f577351c44054196da401414e0479e16a90d6f056 pecl-radius-1.2.4.ebuild 596
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2.1 (GNU/Linux)
+
+iD8DBQFEBDXFaGfFFLhbXWkRAqITAJ9GLIZpGKRhPtDIksmIo0e1LpPkOACfTbPj
+vxluZ81o70VzqhK52ADufCU=
+=XToO
+-----END PGP SIGNATURE-----
diff --git a/dev-php4/pecl-radius/files/digest-pecl-radius-1.2.4 b/dev-php4/pecl-radius/files/digest-pecl-radius-1.2.4
new file mode 100644 (file)
index 0000000..ca84936
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 3d48ccb9486b9e8839d814d7ff318091 radius-1.2.4.tgz 29599
+RMD160 6c886031a750583df3ffa558dc4a0e155fa9dcf4 radius-1.2.4.tgz 29599
+SHA256 500e455ac429044fa33b07bfb07126230efc28fc6e61f8e6fd959dd032009866 radius-1.2.4.tgz 29599
diff --git a/dev-php4/pecl-radius/metadata.xml b/dev-php4/pecl-radius/metadata.xml
new file mode 100644 (file)
index 0000000..fd3dbe3
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php4/pecl-radius/pecl-radius-1.2.4.ebuild b/dev-php4/pecl-radius/pecl-radius-1.2.4.ebuild
new file mode 100644 (file)
index 0000000..c641837
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-radius/pecl-radius-1.2.4.ebuild,v 1.1 2006/02/28 11:36:24 sebastian Exp $
+
+PHP_EXT_NAME="radius"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-pecl-r1
+
+KEYWORDS="~x86"
+DESCRIPTION="Provides full support for RADIUS authentication (RFC 2865) and
+RADIUS accounting (RFC 2866)."
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND="${DEPEND}"
+
+need_php_by_category
+
+src_compile() {
+       has_php
+       my_conf="--with-radius"
+       php-ext-pecl-r1_src_compile
+}