media-sound/pasystray: add missing dependency, minor fixes
authorLouis Sautier <sautier.louis@gmail.com>
Mon, 6 Mar 2017 08:26:42 +0000 (09:26 +0100)
committerDavid Seifert <soap@gentoo.org>
Thu, 9 Mar 2017 20:29:57 +0000 (21:29 +0100)
- use vcs-snapshot instead of setting S
- add xdg-related functions
- use the default src_install
- update LICENSE to include later GPL versions
- remove useless sed

Suggested-By: lmiphay@gmail.com
Bug: https://bugs.gentoo.org/show_bug.cgi?id=605246
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Closes: https://github.com/gentoo/gentoo/pull/4138

media-sound/pasystray/metadata.xml
media-sound/pasystray/pasystray-0.6.0.ebuild

index be6f267a04e6bce6eda1e9a3d9978c21652fdb9f..2499ed091c189228c3655531bd25d7efb7a5747d 100644 (file)
@@ -16,5 +16,6 @@
        </maintainer>
        <upstream>
                <remote-id type="github">christophgysin/pasystray</remote-id>
+               <bugs-to>https://github.com/christophgysin/pasystray/issues</bugs-to>
        </upstream>
 </pkgmetadata>
index 4a7f662207d87339ac115c2699903e18b4e84533..6e99a2f70191a9ff4996882bbd3bf3faf290fe89 100644 (file)
@@ -1,19 +1,20 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
-inherit gnome2-utils autotools
+EAPI=6
+inherit gnome2-utils autotools vcs-snapshot xdg
 
 DESCRIPTION="PulseAudio system tray"
 HOMEPAGE="https://github.com/christophgysin/pasystray"
 SRC_URI="https://github.com/christophgysin/${PN}/archive/${P}.tar.gz"
 
-LICENSE="LGPL-2.1"
+LICENSE="LGPL-2.1+"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE="libnotify"
 
 RDEPEND="
+       >=dev-libs/glib-2.48.2
        >=media-sound/pulseaudio-5.0-r3[glib,zeroconf]
        >=net-dns/avahi-0.6
        x11-libs/gtk+:3
@@ -23,23 +24,28 @@ RDEPEND="
 DEPEND="${RDEPEND}
        virtual/pkgconfig"
 
-DOCS="AUTHORS README.md TODO"
-S=${WORKDIR}/${PN}-${P}
-
 src_prepare() {
+       default
        eautoreconf
 }
+
 src_configure() {
        econf $(use_enable libnotify notify)
-       sed -i -e 's:volume:volume;:' "data/pasystray.desktop"
 }
 
-src_install() {
-       emake DESTDIR="${D}" install
-       dodoc ${DOCS}
-       doman man/pasystray.1
+pkg_preinst() {
+       xdg_pkg_preinst
+       gnome2_icon_savelist
 }
 
-pkg_preinst() {        gnome2_icon_savelist; }
-pkg_postinst() { gnome2_icon_cache_update; }
-pkg_postrm() { gnome2_icon_cache_update; }
+pkg_postinst() {
+       xdg_desktop_database_update
+       xdg_mimeinfo_database_update
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+       xdg_mimeinfo_database_update
+       gnome2_icon_cache_update
+}