net-misc/l7-filter-userspace: update to EAPI 7
authorAndrew Savchenko <bircoph@gentoo.org>
Mon, 4 Nov 2019 18:46:32 +0000 (21:46 +0300)
committerAndrew Savchenko <bircoph@gentoo.org>
Mon, 4 Nov 2019 19:02:53 +0000 (22:02 +0300)
- EAPI 7 bump.
- Copy tarball to devdir since original source is not reliable now.

Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
net-misc/l7-filter-userspace/l7-filter-userspace-0.12_beta1-r1.ebuild [new file with mode: 0644]

diff --git a/net-misc/l7-filter-userspace/l7-filter-userspace-0.12_beta1-r1.ebuild b/net-misc/l7-filter-userspace/l7-filter-userspace-0.12_beta1-r1.ebuild
new file mode 100644 (file)
index 0000000..92e7bc0
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P=${PN}-$(ver_rs 2 -)
+
+DESCRIPTION="Userspace utilities for layer 7 iptables QoS"
+HOMEPAGE="https://l7-filter.clearos.com http://l7-filter.sourceforge.net"
+SRC_URI="https://dev.gentoo.org/~bircoph/distfiles/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+SLOT="0"
+
+DEPEND=">=net-libs/libnetfilter_conntrack-0.0.100
+       >=net-libs/libnetfilter_queue-1.0.0
+       net-libs/libnfnetlink"
+RDEPEND="${DEPEND}
+       net-misc/l7-protocols"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( README TODO BUGS THANKS AUTHORS )
+
+PATCHES=( "${FILESDIR}/${PN}-0.11-libnetfilter_conntrack-0.0.100.patch"
+                 "${FILESDIR}/${PN}-0.11-datatype.patch" )