Bump to version 0.8.3; bug 146408
authorCharlie Shepherd <masterdriverz@gentoo.org>
Tue, 23 Jan 2007 19:30:44 +0000 (19:30 +0000)
committerCharlie Shepherd <masterdriverz@gentoo.org>
Tue, 23 Jan 2007 19:30:44 +0000 (19:30 +0000)
Package-Manager: portage-2.1.2_rc4-r3

dev-libs/libofx/ChangeLog
dev-libs/libofx/files/digest-libofx-0.8.3 [new file with mode: 0644]
dev-libs/libofx/libofx-0.8.0-r1.ebuild
dev-libs/libofx/libofx-0.8.3.ebuild [new file with mode: 0644]

index a045a2582724cb83ce5852cc53d92bd2e845eff3..54ee0c7a8a674edd04ce3a03d3cd19da1f76c899 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-libs/libofx
 # Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libofx/ChangeLog,v 1.29 2007/01/06 03:43:34 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libofx/ChangeLog,v 1.30 2007/01/23 19:30:44 masterdriverz Exp $
+
+*libofx-0.8.3 (23 Jan 2007)
+
+  23 Jan 2007; Charlie Shepherd <masterdriverz@gentoo.org>
+  -libofx-0.7.0-r1.ebuild, libofx-0.8.0-r1.ebuild, +libofx-0.8.3.ebuild:
+  Bump to version 0.8.3; bug 146408
 
   06 Jan 2007; Danny van Dyk <kugelfang@gentoo.org> -libofx-0.6.4.ebuild,
   -libofx-0.6.4-r1.ebuild, -libofx-0.6.5.ebuild, -libofx-0.6.6.ebuild:
diff --git a/dev-libs/libofx/files/digest-libofx-0.8.3 b/dev-libs/libofx/files/digest-libofx-0.8.3
new file mode 100644 (file)
index 0000000..f18d558
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 26ef343ebf93dc6351c889a402e10d89 libofx-0.8.3.tar.gz 971250
+RMD160 a5c9acd6af4ce252d5a0941c82436af72961cd7c libofx-0.8.3.tar.gz 971250
+SHA256 bcba43e92468fc007b40af263ed229c4834b0b65cd556fd456530c0509e46ce4 libofx-0.8.3.tar.gz 971250
index f7d351045c89be163527e3e903c03cb77b8df047..88c9854c7a3fe5a7627209e3d29e3dbc3dd0af38 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libofx/libofx-0.8.0-r1.ebuild,v 1.9 2006/02/04 18:47:01 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libofx/libofx-0.8.0-r1.ebuild,v 1.10 2007/01/23 19:30:44 masterdriverz Exp $
 
 inherit eutils
 
@@ -15,24 +15,22 @@ IUSE=""
 
 RDEPEND=">=app-text/opensp-1.5
         >=net-misc/curl-7.9.7"
-DEPEND="${RDEPEND}
-       >=sys-apps/sed-4"
+DEPEND="${RDEPEND}"
 
 src_unpack() {
        unpack ${A}
-
-       # because we redefine docdir in src_install, we need to make sure the
-       # dtd's go to the right place, LIBOFX_DTD_DIR
-       cd "${S}"/dtd
-       sed -i -e 's/$(DESTDIR)$(docdir)/$(DESTDIR)$(LIBOFX_DTD_DIR)/g' \
-               Makefile.in
-
        cd "${S}"
+
        # bug 116208
        epatch "${FILESDIR}"/${P}-tree.diff
+
+       # because we redefine docdir in src_install, we need to make sure the
+       # dtd's go to the right place, LIBOFX_DTD_DIR
+       cd dtd
+       sed -i -e 's/$(DESTDIR)$(docdir)/$(DESTDIR)$(LIBOFX_DTD_DIR)/g' Makefile.in
 }
 
 src_install() {
        dodir /usr/share/doc/${PF}
-       einstall docdir="${D}"/usr/share/doc/${PF} || die
+       einstall docdir="${D}/usr/share/doc/${PF}" || die
 }
diff --git a/dev-libs/libofx/libofx-0.8.3.ebuild b/dev-libs/libofx/libofx-0.8.3.ebuild
new file mode 100644 (file)
index 0000000..dac90a7
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libofx/libofx-0.8.3.ebuild,v 1.1 2007/01/23 19:30:44 masterdriverz Exp $
+
+inherit eutils
+
+DESCRIPTION="Library to support the Open Financial eXchange XML Format"
+HOMEPAGE="http://libofx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/libofx/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=app-text/opensp-1.5
+        >=net-misc/curl-7.9.7"
+
+src_unpack() {
+       unpack ${A}
+
+       # because we redefine docdir in src_install, we need to make sure the
+       # dtd's go to the right place, LIBOFX_DTD_DIR
+       cd "${S}/dtd"
+       sed -i -e 's/$(DESTDIR)$(docdir)/$(DESTDIR)$(LIBOFX_DTD_DIR)/g' \
+               Makefile.in
+}
+
+src_install() {
+       dodir /usr/share/doc/${PF}
+       make install DESTDIR="${D}" docdir="/usr/share/doc/${PF}" || die 'install failed'
+}